aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2014-10-15 15:48:16 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2014-10-15 15:48:16 +0000
commit8f7f02ae397da7ce0cf9c3bc16b5d117807c1949 (patch)
treec910dffa13397137a5faa661668aff88ff8d1a77 /Mk/bsd.gecko.mk
parent1e031a5acaf339c80a2eeb256a08eb0d691a7d13 (diff)
downloadports-8f7f02ae397da7ce0cf9c3bc16b5d117807c1949.tar.gz
ports-8f7f02ae397da7ce0cf9c3bc16b5d117807c1949.zip
- Update Firefox to 33.0
- Update Firefox ESR to 31.2.0 - Update NSS to 3.17.2 - Update Thunderbird to 31.2.0 - Update libxul to 31.2.0 (and mark as BROKEN) - Disable SSL 3.0 with pref (Upstream bug 1076983) - (workaround) replace USE_GCC=yes with USES=compiler:gcc-c++11-lib in order to fix runtime for PGO and powerpc/powerpc64 on libc++ systems - Add OSS audio fallback for HTML5 audio from upstream bug; not exposed yet because WebRTC still needs ALSA or PulseAudio - Kill @dirrm from gecko@ ports per CHANGES from 20140922 - Drop workaround for LLVM PR 19007: base and lang/clang34 have the fix - Improve workaround comment for LLVM PR 15840, partially rejecting r348851 by marino@ until bug 193555 PR: 194356 Submitted by: Jan Beich Security: http://www.vuxml.org/freebsd/9c1495ac-8d8c-4789-a0f3-8ca6b476619c.html
Notes
Notes: svn path=/head/; revision=370932
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk21
1 files changed, 4 insertions, 17 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index b4eaa6ae506d..d9e7b0464e00 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -94,7 +94,6 @@ USE_XORG= xext xrender xt
MOZILLA_SUFX?= none
MOZSRC?= ${WRKSRC}
WRKSRC?= ${WRKDIR}/mozilla
-PLISTD?= ${WRKDIR}/plist_dirs
PLISTF?= ${WRKDIR}/plist_files
MOZ_PIS_DIR?= lib/${MOZILLA}/init.d
@@ -254,11 +253,7 @@ MOZ_TOOLKIT= cairo-gtk3
USE_MOZILLA+= -cairo # ports/169343
USE_DISPLAY=yes # install
USE_GNOME+= pango
-. if ${MOZILLA_VER:R:R} >= 30 || ${MOZILLA} == "seamonkey"
USE_QT5+= qmake_build buildtools_build gui network quick printsupport
-. else
-USE_QT4+= qmake_build moc_build rcc_build gui network opengl
-. endif
MOZ_EXPORT+= HOST_QMAKE="${QMAKE}" HOST_MOC="${MOC}" HOST_RCC="${RCC}"
.elif ${MOZ_TOOLKIT:Mcairo-gtk3}
USE_GNOME+= gtk30
@@ -287,13 +282,8 @@ MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.endif
.if ${PORT_OPTIONS:MGSTREAMER}
-. if ${MOZILLA_VER:R:R} >= 30 || ${MOZILLA} == "seamonkey"
USE_GSTREAMER1?=good libav
MOZ_OPTIONS+= --enable-gstreamer=1.0
-. else
-USE_GSTREAMER?= good ffmpeg
-MOZ_OPTIONS+= --enable-gstreamer
-. endif
.else
MOZ_OPTIONS+= --disable-gstreamer
.endif
@@ -337,7 +327,7 @@ MOZ_OPTIONS+= --disable-libproxy
.endif
.if ${PORT_OPTIONS:MPGO}
-USE_GCC?= yes
+USES:= compiler:gcc-c++11-lib ${USES:Ncompiler*c++11*}
USE_DISPLAY=yes
.undef GNU_CONFIGURE
@@ -449,7 +439,7 @@ LIBS+= -lcxxrt
. endif
. endif
.elif ${ARCH:Mpowerpc*}
-USE_GCC?= yes
+USES:= compiler:gcc-c++11-lib ${USES:Ncompiler*c++11*}
CFLAGS+= -D__STDC_CONSTANT_MACROS
. if ${ARCH} == "powerpc64"
MOZ_EXPORT+= UNAME_m="${ARCH}"
@@ -600,15 +590,12 @@ port-post-install:
gecko-create-plist:
# Create the plist
- ${RM} -f ${PLISTF} ${PLISTD}
+ ${RM} -f ${PLISTF}
.for dir in ${MOZILLA_PLIST_DIRS}
@cd ${STAGEDIR}${PREFIX}/${dir} && ${FIND} -H -s * ! -type d | \
- ${SED} -e 's|^|${dir}/|' >> ${PLISTF} && \
- ${FIND} -d * -type d | \
- ${SED} -e 's|^|@dirrm ${dir}/|' >> ${PLISTD}
+ ${SED} -e 's|^|${dir}/|' >> ${PLISTF}
.endfor
${CAT} ${PLISTF} | ${SORT} >> ${TMPPLIST}
- ${CAT} ${PLISTD} | ${SORT} -r >> ${TMPPLIST}
gecko-moz-pis-pre-install:
.if defined(MOZ_PIS_SCRIPTS)