aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-07-04 11:40:41 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-07-04 11:40:41 +0000
commite94016c23b7f8963fc0786245da2a36e963371dd (patch)
treeb11c1a697a1b684d54a53c8198a80efb391b3b21 /Mk/bsd.gecko.mk
parent5c3a510f7c3e9cbd92b057d16188a0738965ebda (diff)
downloadports-e94016c23b7f8963fc0786245da2a36e963371dd.tar.gz
ports-e94016c23b7f8963fc0786245da2a36e963371dd.zip
gecko: drop MOZ_* variables controlling defaults
Notes
Notes: svn path=/head/; revision=505830
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk23
1 files changed, 4 insertions, 19 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index c8237a96096a..71f72321dbf5 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -51,12 +51,6 @@ Gecko_Pre_Include= bsd.gecko.mk
# to .mozconfig). If NOMOZCONFIG is defined, you
# probably want to set MAKE_ENV+=${MOZ_EXPORT}
#
-# MOZ_CHROME A variable for the --enable-chrome-format= in
-# CONFIGURE_ARGS. The default is omni.
-#
-# MOZ_TOOLKIT A variable for the --enable-default-toolkit= in
-# CONFIGURE_ARGS. The default is cairo-gtk3.
-#
# NOMOZCONFIG Don't drop a customized .mozconfig into the build
# directory. Options will have to be specified in
# CONFIGURE_ARGS instead
@@ -209,16 +203,11 @@ BUILD_DEPENDS+= ${-${dep}_BUILD_DEPENDS}
.endfor
# Standard options
-MOZ_CHROME?= omni
-MOZ_TOOLKIT?= cairo-gtk3
-MOZ_CHANNEL?= ${PKGNAMESUFFIX:Urelease:S/^-//}
MOZ_OPTIONS+= \
- --enable-chrome-format=${MOZ_CHROME} \
- --enable-default-toolkit=${MOZ_TOOLKIT} \
- --enable-update-channel=${MOZ_CHANNEL} \
- --disable-updater
-# others
-MOZ_OPTIONS+= --with-system-zlib \
+ --enable-default-toolkit=cairo-gtk3${PORT_OPTIONS:MWAYLAND:tl:C/.+/-&/} \
+ --enable-update-channel=${PKGNAMESUFFIX:Urelease:S/^-//} \
+ --disable-updater \
+ --with-system-zlib \
--with-system-bz2
# API keys from www/chromium
@@ -228,10 +217,6 @@ MOZ_OPTIONS+= --with-system-zlib \
MOZ_EXPORT+= MOZ_GOOGLE_LOCATION_SERVICE_API_KEY=AIzaSyBsp9n41JLW8jCokwn7vhoaMejDFRd1mp8
MOZ_EXPORT+= MOZ_GOOGLE_SAFEBROWSING_API_KEY=AIzaSyBsp9n41JLW8jCokwn7vhoaMejDFRd1mp8
-.if ${PORT_OPTIONS:MWAYLAND}
-MOZ_TOOLKIT= cairo-gtk3-wayland
-.endif
-
.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -O3
MOZ_EXPORT+= MOZ_OPTIMIZE_FLAGS="${CFLAGS:M-O*}"