aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-08-04 09:11:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-08-04 09:11:25 +0000
commitf92079c61ea2516fd5b1514bae10c743ba63b699 (patch)
tree1e9acf477fa72cf7c888cc484c96bd4f207a487a /Mk/bsd.gecko.mk
parent397fa72062e7ed8fab7c8a395a1f9475d9723709 (diff)
downloadports-f92079c61ea2516fd5b1514bae10c743ba63b699.tar.gz
ports-f92079c61ea2516fd5b1514bae10c743ba63b699.zip
Update mozilla ports:
- firefox 31.0 - firefox-esr 24.7.0 - libxul 24.7.0 - seamonkey 2.26.1 - thunderbird 31.0 Among changes: - add workaround for crash with openldap on thunderbird and seamonkey [1] - add crashfix for architectures with strict alignmentment - backport crashfix with system sqlite/nss on firefox-esr and thunderbird - restore hooking jemalloc in sqlite on freebsd 10+ - fix thunderbird build with -jN [2] - respect MAKE_JOBS_NUMBER regardless of kern.smp.cpus [2] - define CPE_URI for nspr/nss and firefox/thunderbird/seamonkey - require recent gstreamer1-libav i386 crashfix - add DTRACE option for use with DTraceToolkit (js_flowtime.d, js_who.d, etc) PR: 165263 [1] PR: 184630 [2] Submitted by: Jan Beich
Notes
Notes: svn path=/head/; revision=363978
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk25
1 files changed, 23 insertions, 2 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 4f3f6feaf543..a133e17bee98 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -85,7 +85,8 @@ MOZILLA_VER?= ${PORTVERSION}
MOZILLA_BIN?= ${PORTNAME}-bin
MOZILLA_EXEC_NAME?=${MOZILLA}
MOZ_RPATH?= ${MOZILLA}
-USES+= compiler:c++11-lib gmake iconv perl5 pkgconfig desktop-file-utils
+USES+= cpe compiler:c++11-lib gmake iconv perl5 pkgconfig desktop-file-utils
+CPE_VENDOR?=mozilla
USE_PERL5= build
USE_XORG= xext xrender xt
@@ -185,7 +186,7 @@ pixman_EXTRACT_AFTER_ARGS= --exclude mozilla*/gfx/cairo/libpixman
png_LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
png_MOZ_OPTIONS= --with-system-png=${LOCALBASE}
-png_EXTRACT_AFTER_ARGS= --exclude mozilla*/media/libpng
+#png_EXTRACT_AFTER_ARGS= --exclude mozilla*/media/libpng
.if exists(${FILESDIR}/patch-z-bug517422) || exists(${FILESDIR}/patch-zz-bug517422)
soundtouch_LIB_DEPENDS= libSoundTouch.so:${PORTSDIR}/audio/soundtouch
@@ -394,6 +395,15 @@ STRIP= # ports/184285
MOZ_OPTIONS+= --disable-debug --enable-release
.endif
+.if ${PORT_OPTIONS:MDTRACE}
+. if ${OSVERSION} < 1000510
+BROKEN= dtrace -G crashes with C++ object files
+. endif
+MOZ_OPTIONS+= --enable-dtrace
+LIBS+= -lelf
+STRIP=
+.endif
+
.if ${PORT_OPTIONS:MLOGGING} || ${PORT_OPTIONS:MDEBUG}
MOZ_OPTIONS+= --enable-logging
.else
@@ -420,6 +430,17 @@ MOZ_OPTIONS+= --disable-strip --disable-install-strip
MOZ_OPTIONS+= --enable-strip --enable-install-strip
.endif
+# _MAKE_JOBS is only available after bsd.port.post.mk, thus cannot be
+# used in .mozconfig. And client.mk automatically uses -jN where N
+# is what multiprocessing.cpu_count() returns.
+.if defined(MAKE_JOBS_NUMBER)
+MOZ_MAKE_FLAGS+=-j${MAKE_JOBS_NUMBER}
+.endif
+
+.if defined(MOZ_MAKE_FLAGS)
+MOZ_MK_OPTIONS+=MOZ_MAKE_FLAGS="${MOZ_MAKE_FLAGS}"
+.endif
+
MOZ_SED_ARGS+= -e's|@CPPFLAGS@|${CPPFLAGS}|g' \
-e 's|@CFLAGS@|${CFLAGS}|g' \
-e 's|@LDFLAGS@|${LDFLAGS}|g' \