aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2011-08-18 10:05:44 +0000
committerAlex Dupre <ale@FreeBSD.org>2011-08-18 10:05:44 +0000
commit5d3919e668d29f30bbb4e7a4d77b6ad2e5f733ac (patch)
tree241779f362a148bdc2d0f78068efbe13d6bd2da7 /Mk/bsd.gecko.mk
parent1f777079ab894afbb579662c608f72314c40dae9 (diff)
downloadports-5d3919e668d29f30bbb4e7a4d77b6ad2e5f733ac.tar.gz
ports-5d3919e668d29f30bbb4e7a4d77b6ad2e5f733ac.zip
Notes
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk16
1 files changed, 10 insertions, 6 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 5c700383ae5a..7bd0d36dce6d 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -236,10 +236,10 @@ USE_FIREFOX= ${_FIREFOX_DEFAULT_VERSION}
.endif
# Setting/finding Firefox version we want.
-.if exists(${LOCALBASE}/bin/firefox3)
-_FIREFOX_VER!= ${LOCALBASE}/bin/firefox3 --version | ${SED} -e 's/Mozilla Firefox \([0-9]\)\.\([0-9]*\).*/\1\2/'
-.elif exists(${LOCALBASE}/bin/firefox)
+.if exists(${LOCALBASE}/bin/firefox)
_FIREFOX_VER!= ${LOCALBASE}/bin/firefox --version | ${SED} -e 's/Mozilla Firefox \([0-9]\)\.\([0-9]*\).*/\1\2/'
+.elif exists(${LOCALBASE}/bin/firefox3)
+_FIREFOX_VER!= ${LOCALBASE}/bin/firefox3 --version | ${SED} -e 's/Mozilla Firefox \([0-9]\)\.\([0-9]*\).*/\1\2/'
.endif
# Check if installed Firefox version matches the wanted one
@@ -311,6 +311,8 @@ USE_SEAMONKEY= ${_SEAMONKEY_DEFAULT_VERSION}
# Setting/finding SeaMonkey version we want.
.if exists(${LOCALBASE}/bin/seamonkey)
_SEAMONKEY_VER!= ${LOCALBASE}/bin/seamonkey --version | ${SED} -e 's/Mozilla SeaMonkey \([0-9]\)\.\([0-9]*\).*/\1\2/'
+.elif exists(${LOCALBASE}/bin/seamonkey2)
+_SEAMONKEY_VER!= ${LOCALBASE}/bin/seamonkey2 --version | ${SED} -e 's/Mozilla SeaMonkey \([0-9]\)\.\([0-9]*\).*/\1\2/'
.endif
# Check if installed SeaMonkey version matches the wanted one
@@ -343,8 +345,8 @@ IGNORE= cannot install: unknown SeaMonkey version: seamonkey-${USE_SEAMONKEY:C
.endif
# Dependence lines for different SeaMonkey versions
-11_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey-bin:${PORTSDIR}/www/seamonkey
-20_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey:${PORTSDIR}/www/seamonkey2
+23_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey:${PORTSDIR}/www/seamonkey
+20_DEPENDS= ${LOCALBASE}/lib/seamonkey2/seamonkey:${PORTSDIR}/www/seamonkey2
# Add dependencies
.if defined(USE_SEAMONKEY)
@@ -382,6 +384,8 @@ USE_THUNDERBIRD= ${_THUNDERBIRD_DEFAULT_VERSION}
# Setting/finding Thunderbird version we want.
.if exists(${LOCALBASE}/bin/thunderbird)
_THUNDERBIRD_VER!= ${LOCALBASE}/bin/thunderbird --version | ${SED} -e 's/ Thunderbird \([0-9]\)\.\([0-9]*\).*/\1\2/'
+.elif exists(${LOCALBASE}/bin/thunderbird3)
+_THUNDERBIRD_VER!= ${LOCALBASE}/bin/thunderbird3 --version | ${SED} -e 's/ Thunderbird \([0-9]\)\.\([0-9]*\).*/\1\2/'
.endif
# Check if installed Thunderbird version matches the wanted one
@@ -415,7 +419,7 @@ IGNORE= cannot install: unknown Thunderbird version: thunderbird-${USE_THUNDER
# Dependence lines for different Thunderbird versions
60_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird
-31_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird3
+31_DEPENDS= ${LOCALBASE}/lib/thunderbird3/thunderbird:${PORTSDIR}/mail/thunderbird3
# Add dependencies
.if defined(USE_THUNDERBIRD)