aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-11-20 18:55:42 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-11-20 18:55:42 +0000
commit1bfb54119658886bda56773f280c32805ef4b089 (patch)
tree4fed24af5fdc8c624d238947f1f14fe79a2b5102 /Mk/bsd.gecko.mk
parent493ad91428927ed236873df06c443647d66d0dac (diff)
downloadports-1bfb54119658886bda56773f280c32805ef4b089.tar.gz
ports-1bfb54119658886bda56773f280c32805ef4b089.zip
Notes
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk26
1 files changed, 1 insertions, 25 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 4b81a7cb3d7c..2ad5d15aab3f 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -167,14 +167,7 @@ MOZ_OPTIONS+= --enable-jemalloc=4
.endif # Mozilla < 55
# Standard depends
-_ALL_DEPENDS= cairo event ffi graphite harfbuzz hunspell icu jpeg nspr nss png pixman soundtouch sqlite vpx
-
-.if ${PORT_OPTIONS:MINTEGER_SAMPLES}
-MOZ_EXPORT+= MOZ_INTEGER_SAMPLES=1
-_ALL_DEPENDS+= tremor
-.else
-_ALL_DEPENDS+= vorbis
-.endif
+_ALL_DEPENDS= cairo event ffi graphite harfbuzz hunspell icu jpeg nspr nss png pixman sqlite vpx
.if ! ${PORT_OPTIONS:MBUNDLED_CAIRO}
cairo_BUILD_DEPENDS=cairo>=1.12.16_1,2:graphics/cairo
@@ -218,26 +211,9 @@ pixman_MOZ_OPTIONS= --enable-system-pixman
png_LIB_DEPENDS= libpng.so:graphics/png
png_MOZ_OPTIONS= --with-system-png=${LOCALBASE}
-.if exists(${FILESDIR}/patch-z-bug517422)
-soundtouch_LIB_DEPENDS= libSoundTouch.so:audio/soundtouch
-soundtouch_MOZ_OPTIONS= --with-system-soundtouch
-.endif
-
sqlite_LIB_DEPENDS= libsqlite3.so:databases/sqlite3
sqlite_MOZ_OPTIONS= --enable-system-sqlite
-.if exists(${FILESDIR}/patch-z-bug517422)
-# XXX disabled: update to 1.2.x or review backported fixes
-theora_LIB_DEPENDS= libtheora.so:multimedia/libtheora
-theora_MOZ_OPTIONS= --with-system-theora
-
-tremor_LIB_DEPENDS= libogg.so:audio/libogg libvorbisidec.so:audio/libtremor
-tremor_MOZ_OPTIONS= --with-system-tremor --with-system-ogg
-
-vorbis_LIB_DEPENDS= libogg.so:audio/libogg libvorbis.so:audio/libvorbis
-vorbis_MOZ_OPTIONS= --with-system-vorbis --with-system-ogg
-.endif
-
-vpx_BUILD_DEPENDS= yasm:devel/yasm
vpx_LIB_DEPENDS= libvpx.so:multimedia/libvpx
vpx_MOZ_OPTIONS= --with-system-libvpx