aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-10-28 17:03:28 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-10-28 17:03:28 +0000
commit912a7b12e4e109551df76471e1e446eb4d5a8b37 (patch)
treebfdd16290ece91145dc3df1818b888573eface15 /Mk/bsd.gecko.mk
parent8866b5a40d11eb5d621edb42874296c743c1bcec (diff)
downloadports-912a7b12e4e109551df76471e1e446eb4d5a8b37.tar.gz
ports-912a7b12e4e109551df76471e1e446eb4d5a8b37.zip
Notes
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index d7febeb00386..eaa44ae651ba 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -659,8 +659,8 @@ MOZ_OPTIONS+= --with-system-zlib \
--disable-updater \
--disable-pedantic
-.if ${CXXFLAGS:M-stdlib=libc++}
-LIBS+= -lcxxrt
+.if exists(/usr/lib/libcxxrt.so)
+LIBS+= -Wl,--as-needed,-lcxxrt,--no-as-needed
.endif
.if ${PORT_OPTIONS:MQT4}
@@ -723,6 +723,7 @@ MOZ_OPTIONS+= --disable-gnomeui
.if ${PORT_OPTIONS:MGNOMEVFS2}
USE_GNOME+= gnomevfs2
MOZ_OPTIONS+= --enable-gnomevfs
+MOZ_OPTIONS:= ${MOZ_OPTIONS:C/(extensions)=(.*)/\1=\2,gnomevfs/}
.else
MOZ_OPTIONS+= --disable-gnomevfs
.endif