aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gnustep.mk
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-11-19 20:52:08 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-11-19 20:52:08 +0000
commit6bc90c25ec36c5c2d89ea6f913c9859d145817f9 (patch)
tree10a801516ba2884d049e49aace4ceb3a3794075c /Mk/bsd.gnustep.mk
parent53689fc456813a03b517d65c170805443b55057f (diff)
downloadports-6bc90c25ec36c5c2d89ea6f913c9859d145817f9.tar.gz
ports-6bc90c25ec36c5c2d89ea6f913c9859d145817f9.zip
Notes
Diffstat (limited to 'Mk/bsd.gnustep.mk')
-rw-r--r--Mk/bsd.gnustep.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/Mk/bsd.gnustep.mk b/Mk/bsd.gnustep.mk
index a38f2c02fbaf..8287e99d4e89 100644
--- a/Mk/bsd.gnustep.mk
+++ b/Mk/bsd.gnustep.mk
@@ -72,6 +72,9 @@
# USE_GNUSTEP_SYSTEM_LIBS+= Renaissance:x11-toolkits/renaissance
# depends on a shared lib in System directrory
#
+# USE_GNUSTEP_SYSTEM_BUNDLES+= EtoileMenus:x11-themes/etoile-etoilemenus
+# depends on Bundles installed in System directrory at build and runtime
+#
# USE_GNUSTEP_LOCAL_LIBS+= pantomime:mail/pantomime
# depends on a shared lib in Local directrory
#
@@ -274,6 +277,16 @@ RUN_DEPENDS+= ${COMBOLIBDIR}/lib${_GNUSTEP_DEP:C/:.*//}.so:${PORTSDIR}/${_GNUSTE
.endif
# ---------------------------------------------------------------------------
+# source system bundles
+#
+.if defined(USE_GNUSTEP_SYSTEM_BUNDLES)
+.for _GNUSTEP_DEP in ${USE_GNUSTEP_SYSTEM_BUNDLES}
+BUILD_DEPENDS+= ${BUNDLEDIR}/${_GNUSTEP_DEP:C/:.*//}.bundle/${_GNUSTEP_DEP:C/:.*//}:${PORTSDIR}/${_GNUSTEP_DEP:C/.*://}
+RUN_DEPENDS+= ${BUNDLEDIR}/${_GNUSTEP_DEP:C/:.*//}.bundle/${_GNUSTEP_DEP:C/:.*//}:${PORTSDIR}/${_GNUSTEP_DEP:C/.*://}
+.endfor
+.endif
+
+# ---------------------------------------------------------------------------
# source local libs
#
.if defined(USE_GNUSTEP_LOCAL_LIBS)