aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gstreamer.mk
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-08 07:17:24 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-08 07:17:24 +0000
commiteee8c71af2c46f56f5af20ee2039d2330336b0c2 (patch)
tree3595d086207443ad9fce670865bb4b395ac922c1 /Mk/bsd.gstreamer.mk
parent3d18a27d2ee77ddfb722ebcea07e7c25657176a4 (diff)
downloadports-eee8c71af2c46f56f5af20ee2039d2330336b0c2.tar.gz
ports-eee8c71af2c46f56f5af20ee2039d2330336b0c2.zip
Notes
Diffstat (limited to 'Mk/bsd.gstreamer.mk')
-rw-r--r--Mk/bsd.gstreamer.mk21
1 files changed, 12 insertions, 9 deletions
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index 50e3d96f181a..348bf78dc3e3 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -52,13 +52,14 @@ GST_SHLIB_VERSION= 1
#
# These are the current supported gstreamer-plugins modules
#
-_USE_GSTREAMER_ALL= a52dec aalib artsd audiofile cdaudio cdparanoia dirac \
- dts dv dvd esound faac faad ffmpeg flac gdkpixbuf \
- gnomevfs gsm hermes ivorbis jack jpeg jpeg-mmx ladspa \
- lame libcaca libfame libmng libpng libvisual mad mikmod \
- mpeg2dec mpeg2enc mplex musepack musicbrainz nas sdl \
- shout sidplay smoothwave sndfile speex theora ogg pango \
- polypaudio swfdec vorbis xine xvid
+_USE_GSTREAMER_ALL= a52dec aalib artsd audiofile cairo cdaudio cdparanoia \
+ dirac dts dv dvd esound faac faad ffmpeg flac \
+ gdkpixbuf gnomevfs gsm hermes ivorbis jack jpeg \
+ jpeg-mmx ladspa lame libcaca libfame libmng libpng \
+ libvisual mad mikmod mpeg2dec mpeg2enc mplex musepack \
+ musicbrainz nas sdl shout sidplay smoothwave sndfile \
+ speex theora ogg pango polypaudio swfdec vorbis xine \
+ xvid
# other plugins
OTHER_GSTREAMER_PLUGINS+= core yes
@@ -143,6 +144,8 @@ sdl_PLIST= libgstsdlvideosink
aalib_DEPENDS= graphics/gstreamer-plugins-aalib
aalib_PLIST= libgstaasink
+cairo_DEPENDS= graphics/gstreamer-plugins-cairo
+
gdkpixbuf_DEPENDS= graphics/gstreamer-plugins-gdkpixbuf
hermes_DEPENDS= graphics/gstreamer-plugins-hermes
@@ -166,8 +169,6 @@ libvisual_DEPNDS= graphics/gstreamer-plugins-libvisual
swfdec_DEPENDS= graphics/gstreamer-plugins-swfdec
-theora_DEPENDS= multimedia/gstreamer-plugins-theora
-
# Multimedia Plugins Section
dirac_DEPENDS= multimedia/gstreamer-plugins-dirac
@@ -192,6 +193,8 @@ mpeg2enc_DEPENDS= multimedia/gstreamer-plugins-mpeg2enc
mplex_DEPENDS= multimedia/gstreamer-plugins-mplex
+theora_DEPENDS= multimedia/gstreamer-plugins-theora
+
xine_DEPENDS= multimedia/gstreamer-plugins-xine
xvid_DEPENDS= multimedia/gstreamer-plugins-xvid