aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.licenses.mk
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2012-06-26 15:27:54 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2012-06-26 15:27:54 +0000
commit988fb33cd31eda5918a40a688650e6a21af31d2e (patch)
tree62eefe9190074e1080514a835e3612b7a8c33e58 /Mk/bsd.licenses.mk
parent05afdfec720715739d958e3cef47e33119164000 (diff)
Notes
Diffstat (limited to 'Mk/bsd.licenses.mk')
-rw-r--r--Mk/bsd.licenses.mk19
1 files changed, 10 insertions, 9 deletions
diff --git a/Mk/bsd.licenses.mk b/Mk/bsd.licenses.mk
index dd945baf9723..e20a759a9e3f 100644
--- a/Mk/bsd.licenses.mk
+++ b/Mk/bsd.licenses.mk
@@ -558,27 +558,26 @@ clean-for-cdrom-list:
# Check variables are correctly defined and print status up to here
+.if ${_LICENSE_STATUS} == "ask" && defined(BATCH)
+IGNORE= License ${_LICENSE} needs confirmation, but BATCH is defined
+.endif
+
check-license:
.if defined(_LICENSE_ERROR)
@${ECHO_MSG} "===> License not correctly defined: ${_LICENSE_ERROR}"
@exit 1
.endif
-. if ${_LICENSE_STATUS} == "rejected"
+.if ${_LICENSE_STATUS} == "rejected"
@${ECHO_MSG} "===> License ${_LICENSE} rejected by the user"
@${ECHO_MSG}
@${ECHO_MSG} "If you want to install this port make sure the following license(s) are not present in LICENSES_REJECTED, either in make arguments or /etc/make.conf: ${_LICENSE}. Also check LICENSES_GROUPS_REJECTED in case they contain a group this license(s) belong to." | ${FMT}
@${ECHO_MSG}
@exit 1
-. elif ${_LICENSE_STATUS} == "accepted"
+.elif ${_LICENSE_STATUS} == "accepted"
@${ECHO_MSG} "===> License ${_LICENSE} accepted by the user"
-. elif ${_LICENSE_STATUS} == "ask"
-. if defined(BATCH)
- @${ECHO_MSG} "===> License ${_LICENSE} needs confirmation, but BATCH is defined"
- @exit 1
-. else
+.elif ${_LICENSE_STATUS} == "ask"
@${ECHO_MSG} "===> License ${_LICENSE} needs confirmation, will ask later"
-. endif
-. endif
+.endif
# Display, ask and save preference if requested
@@ -775,7 +774,9 @@ install-license:
.else # !LICENSE
check-license:
+. if defined(LICENSE_VERBOSE)
@${ECHO_MSG} "===> License check disabled, port has not defined LICENSE"
+. endif
.endif # LICENSE