aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.licenses.mk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-08-20 12:15:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-08-20 12:15:02 +0000
commit4a4e54a80a97823a4ea02b5bd45d4ca03fe739d2 (patch)
tree5538f478adbf7630b65f29a7f91ebc66aab528d9 /Mk/bsd.licenses.mk
parente742d91d59ac6181de7f92618c154944d5c3a53f (diff)
downloadports-4a4e54a80a97823a4ea02b5bd45d4ca03fe739d2.tar.gz
ports-4a4e54a80a97823a4ea02b5bd45d4ca03fe739d2.zip
Notes
Diffstat (limited to 'Mk/bsd.licenses.mk')
-rw-r--r--Mk/bsd.licenses.mk14
1 files changed, 5 insertions, 9 deletions
diff --git a/Mk/bsd.licenses.mk b/Mk/bsd.licenses.mk
index 3461107407d6..3c78da0b6602 100644
--- a/Mk/bsd.licenses.mk
+++ b/Mk/bsd.licenses.mk
@@ -42,6 +42,7 @@
# Variables provided to the ports system and users in general, to modify the
# behavior of the framework
#
+# DISABLE_LICENSES - Disable license auditing framework completely.
# NO_LICENSES_INSTALL - Do not install catalog, report and licenses.
# NO_LICENSES_DIALOGS - Disable interactive menus for asking licenses.
@@ -119,7 +120,7 @@
.if defined(_POSTMKINCLUDED) && !defined(BEFOREPORTMK)
-.if defined(LICENSE)
+.if defined(LICENSE) && !defined(DISABLE_LICENSES)
# Include known licenses from database
@@ -720,7 +721,6 @@ ${_LICENSE_COOKIE}:
.if !defined(NO_LICENSES_INSTALL)
PLIST_FILES+= ${_LICENSE_DIR_REL}/${_LICENSE_CATALOG:T} \
${_LICENSE_DIR_REL}/${_LICENSE_REPORT:T}
-PLIST_DIRS+= ${_LICENSE_DIR_REL}
.if ${_LICENSE_COMB} == "single"
PLIST_FILES+= ${_LICENSE_DIR_REL}/${_LICENSE_FILE:T}
@@ -744,6 +744,8 @@ install-license:
. endfor
.endif
# XXX @dirrmtry entry must be here (no way to do with PLIST_* vars)
+ @${ECHO_CMD} "@cwd ${PREFIX}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm ${_LICENSE_DIR_REL}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec rmdir %D/share/licenses 2>/dev/null || true" >> ${TMPPLIST}
.else
@@ -752,17 +754,11 @@ install-license:
.endif
-.else # !LICENSE
+.elif !defined(DISABLE_LICENSES) # !LICENSE
check-license:
@${ECHO_MSG} "===> License check disabled, port has not defined LICENSE"
-ask-license:
- @${DO_NADA}
-
-install-license:
- @${DO_NADA}
-
.endif # LICENSE
.endif