aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.linux-rpm.mk
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2008-08-15 12:29:42 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2008-08-15 12:29:42 +0000
commitce3a776fc1f4ab69f7d475c17a9ea76c9467336c (patch)
treeb12ed80622f51f96ca1834ca17ede714f6a28821 /Mk/bsd.linux-rpm.mk
parente6141bf582c5ce1a6fcbed4424f9c89c44430e85 (diff)
downloadports-ce3a776fc1f4ab69f7d475c17a9ea76c9467336c.tar.gz
ports-ce3a776fc1f4ab69f7d475c17a9ea76c9467336c.zip
Notes
Diffstat (limited to 'Mk/bsd.linux-rpm.mk')
-rw-r--r--Mk/bsd.linux-rpm.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/Mk/bsd.linux-rpm.mk b/Mk/bsd.linux-rpm.mk
index 658841da7a9c..f7aac003d566 100644
--- a/Mk/bsd.linux-rpm.mk
+++ b/Mk/bsd.linux-rpm.mk
@@ -1,7 +1,7 @@
#-*- mode: Makefile; tab-width: 4; -*-
# ex:ts=4
#
-# $FreeBSD: /tmp/pcvs/ports/Mk/bsd.linux-rpm.mk,v 1.12 2008-04-29 19:20:52 bsam Exp $
+# $FreeBSD: /tmp/pcvs/ports/Mk/bsd.linux-rpm.mk,v 1.13 2008-08-15 12:29:42 bsam Exp $
#
# Variables:
@@ -105,6 +105,20 @@ MD5_FILE?= ${MASTERDIR}/distinfo.${LINUX_RPM_ARCH}
BRANDELF_DIRS?=
BRANDELF_FILES?=
+# For ports that define PORTDOCS, be sure not to install
+# documentation if NOPORTDOCS is defined
+. if defined(PORTDOCS) && defined(NOPORTDOCS)
+pre-patch: linux-rpm-clean-portdocs
+
+. if !target(linux-rpm-clean-portdocs)
+linux-rpm-clean-portdocs:
+. for x in ${PORTDOCS}
+ @${RM} -f ${WRKDIR}/${DOCSDIR_REL}/${x}
+. endfor
+ @${RMDIR} ${WRKDIR}/${DOCSDIR_REL}
+. endif
+. endif
+
. if defined(AUTOMATIC_PLIST)
. if ${USE_LINUX} == "fc4" || ${USE_LINUX:L} == "yes"