aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.linux-rpm.mk
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-06-26 17:03:48 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-06-26 17:03:48 +0000
commitd937bad880b871238e5840c65e49e835fc3b2d0b (patch)
tree0a6feb34ded56acee2c3e1c8c140872b0c05adc3 /Mk/bsd.linux-rpm.mk
parent5e42abf6d6691ec03842f7f617f233a1d299b7a1 (diff)
downloadports-d937bad880b871238e5840c65e49e835fc3b2d0b.tar.gz
ports-d937bad880b871238e5840c65e49e835fc3b2d0b.zip
Notes
Diffstat (limited to 'Mk/bsd.linux-rpm.mk')
-rw-r--r--Mk/bsd.linux-rpm.mk23
1 files changed, 18 insertions, 5 deletions
diff --git a/Mk/bsd.linux-rpm.mk b/Mk/bsd.linux-rpm.mk
index 637fcab2daff..22c8574b5656 100644
--- a/Mk/bsd.linux-rpm.mk
+++ b/Mk/bsd.linux-rpm.mk
@@ -1,7 +1,7 @@
#-*- mode: Makefile; tab-width: 4; -*-
# ex:ts=4
#
-# $FreeBSD: /tmp/pcvs/ports/Mk/bsd.linux-rpm.mk,v 1.20 2009-06-17 18:53:57 bsam Exp $
+# $FreeBSD: /tmp/pcvs/ports/Mk/bsd.linux-rpm.mk,v 1.21 2009-06-26 17:03:48 bsam Exp $
#
# Variables:
@@ -63,7 +63,15 @@ LINUX_RPM_ARCH?= ${ARCH}
Linux_RPM_Post_Include= bsd.linux-rpm.mk
LINUX_DIST?= fedora
+. if ${OSVERSION} < 800076
LINUX_DIST_VER?= 4
+. else
+LINUX_DIST_VER?= 10
+. if !defined(${OVERRIDE_LINUX_NONBASE_PORTS}) && \
+ ${LINUX_DIST_VER} != 10
+IGNORE= bsd.linux-rpm.mk test failed: default package building at OSVERSION>=800076 was changed to linux-f10 ports, please define OVERRIDE_LINUX_NONBASE_PORTS to build other linux infrastructure ports
+. endif
+. endif
# linux Fedora 8 infrastructure ports should be used with compat.linux.osrelease=2.6.16,
# linux_base-f8 (or greater) port
@@ -72,14 +80,19 @@ LINUX_DIST_VER?= 4
. if (${LINUX_OSRELEASE} != "2.6.16")
IGNORE= bsd.linux-rpm.mk test failed: the port should be used with compat.linux.osrelease=2.6.16, which is supported at 8-CURRENT and has a limitted support at 7-STABLE
. endif
+# the default for OSVERSION < 800076
+. if ${OSVERSION} < 800076
# let's check if an apropriate linux base port is used
-. if ${USE_LINUX} != f8 && ${USE_LINUX} != f9 && ${USE_LINUX} != f10
+. if ${USE_LINUX} != f8 && ${USE_LINUX} != f9 && ${USE_LINUX} != f10
IGNORE= bsd.linux-rpm.mk test failed: the port should be used with at least linux_base-f8, please read /usr/ports/UPDATING
-. endif
+. endif
# let's check if OVERRIDE_LINUX_NONBASE_PORTS is defined
-. ifndef(OVERRIDE_LINUX_NONBASE_PORTS)
+. ifndef(OVERRIDE_LINUX_NONBASE_PORTS)
IGNORE= bsd.linux-rpm.mk test failed: the port should be used with defined OVERRIDE_LINUX_NONBASE_PORTS, please read /usr/ports/UPDATING
-. endif
+. endif
+# the default for OSVERSION >= 800076
+#. else
+. endif # ${OSVERSION} < 800076
. endif
. if defined(LINUX_DIST)