aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.local.mk
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2006-01-21 17:37:14 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2006-01-21 17:37:14 +0000
commit01c588a6357d8452a3e0af157e9c1250c067db2f (patch)
treefb26bf418ea8791ab4d308a7931c623124611c3c /Mk/bsd.local.mk
parentf484c99df79f169bf954fc4b0ed83e59279a596a (diff)
downloadports-01c588a6357d8452a3e0af157e9c1250c067db2f.tar.gz
ports-01c588a6357d8452a3e0af157e9c1250c067db2f.zip
Notes
Diffstat (limited to 'Mk/bsd.local.mk')
-rw-r--r--Mk/bsd.local.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/Mk/bsd.local.mk b/Mk/bsd.local.mk
new file mode 100644
index 000000000000..ae6a231a39d2
--- /dev/null
+++ b/Mk/bsd.local.mk
@@ -0,0 +1,31 @@
+# -*- mode: Makefile; tab-width: 4; -*-
+# ex: ts=4
+#
+# bsd.local.mk - Sandbox for local modification to ports framework.
+#
+# Created by: Mark Linimon <linimon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+.if !defined(_POSTMKINCLUDED) && !defined(Local_Pre_Include)
+
+Local_Pre_Include= bsd.local.mk
+
+#
+# here is where any code that needs to run at bsd.port.pre.mk inclusion
+# time should live.
+#
+
+.endif # !defined(_POSTMKINCLUDED) && !defined(Local_Pre_Include)
+
+.if defined(_POSTMKINCLUDED) && !defined(Local_Post_Include)
+
+Local_Post_Include= bsd.local.mk
+
+#
+# here is where any code that needs to run at bsd.port.post.mk inclusion
+# time should live.
+#
+
+.endif # defined(_POSTMKINCLUDED) && !defined(Local_Post_Include)