aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.openssl.mk
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-09-19 15:33:09 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-09-19 15:33:09 +0000
commitf57f2df801179d3c7ae1225aed35d593b8185795 (patch)
treeb2ddb0f0b464aff4949f2cecd78574e2f3337086 /Mk/bsd.openssl.mk
parentb35c32f5afaf6de3ed85017c1cb79bc416e74ea3 (diff)
downloadports-f57f2df801179d3c7ae1225aed35d593b8185795.tar.gz
ports-f57f2df801179d3c7ae1225aed35d593b8185795.zip
Notes
Diffstat (limited to 'Mk/bsd.openssl.mk')
-rw-r--r--Mk/bsd.openssl.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/Mk/bsd.openssl.mk b/Mk/bsd.openssl.mk
index dfdc941e51e7..4282c6342fbf 100644
--- a/Mk/bsd.openssl.mk
+++ b/Mk/bsd.openssl.mk
@@ -1,5 +1,5 @@
#
-# $FreeBSD: /tmp/pcvs/ports/Mk/bsd.openssl.mk,v 1.48 2012-04-18 11:38:20 bapt Exp $
+# $FreeBSD$
# bsd.openssl.mk - Support for OpenSSL based ports.
#
# Use of 'USE_OPENSSL=yes' includes this Makefile after bsd.ports.pre.mk
@@ -8,6 +8,7 @@
#
# WITH_OPENSSL_BASE=yes - Use the version in the base system.
# WITH_OPENSSL_PORT=yes - Use the port, even if base is up to date
+# WITH_OPENSSL_HACK7=yes - Use not the version in the base system on FreeBSD 7.x
#
# USE_OPENSSL_RPATH=yes - Pass RFLAGS options in CFLAGS,
# needed for ports who don't use LDFLAGS
@@ -39,6 +40,13 @@ WITH_OPENSSL_BASE=yes
WITH_OPENSSL_PORT=yes
.endif
+.if defined(WITH_OPENSSL_HACK7)
+.if ${OSVERSION} < 800000
+# the openssl in base of FreeBSD 7.x is too old
+WITH_OPENSSL_PORT?= yes
+.endif
+.endif
+
# if no preference was set, check for an installed base version
# but give an installed port preference over it.
.if !defined(WITH_OPENSSL_BASE) && \