aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-26 17:31:20 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-26 17:31:20 +0000
commitb5485e708b29e582e6e0bbf96f03e8b04175ac76 (patch)
tree7b559e23dcc4d9a72f62cec703bae1e3f51e2617 /Mk/bsd.options.mk
parent9e71ec9d5a1f5e98e47fb0b945712c873c38a15e (diff)
Notes
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 1290d72c3bf2..a73f446116c7 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -35,6 +35,7 @@
#
# OPTIONS_EXCLUDE - List of options unsupported (useful for slave ports)
# OPTIONS_EXCLUDE_${ARCH} - List of options unsupported on a given ${ARCH}
+# OPTIONS_EXCLUDE_${OPSYS} - List of options unsupported on a given ${OPSYS}
# OPTIONS_SLAVE - This is designed for slave ports, it removes an
# option from the options list inherited from the
# master port and it always adds it to PORT_OPTIONS
@@ -171,7 +172,8 @@ OPTIONS_DEFINE+= ${opt}
OPTIONS_DEFAULT+= ${OPTIONS_DEFAULT_${ARCH}}
# Remove options the port maintainer doesn't want
-.for opt in ${OPTIONS_EXCLUDE_${ARCH}} ${OPTIONS_EXCLUDE} ${OPTIONS_SLAVE}
+.for opt in ${OPTIONS_EXCLUDE_${ARCH}} ${OPTIONS_EXCLUDE} ${OPTIONS_SLAVE} \
+ ${OPTIONS_EXCLUDE_${OPSYS}}
OPTIONS_DEFAULT:= ${OPTIONS_DEFAULT:N${opt}}
OPTIONS_DEFINE:= ${OPTIONS_DEFINE:N${opt}}
PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}