aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-11-12 13:23:14 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-11-12 13:23:14 +0000
commit2cc3335d59f8095e8539fd9fc01dcd12aeef7db9 (patch)
tree708d0b31da85eb388d3b06d1fa8abbf0c99e44da /Mk/bsd.options.mk
parent6690bf52a3f1df47439406df5e8a113b15c0f030 (diff)
downloadports-2cc3335d59f8095e8539fd9fc01dcd12aeef7db9.tar.gz
ports-2cc3335d59f8095e8539fd9fc01dcd12aeef7db9.zip
Notes
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 0a59e150050e..a70cf8fb7089 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -95,6 +95,8 @@
#
# ${opt}_USE= FOO=bar When option is enabled, it will enable
# USE_FOO+= bar
+# If you need more than one option, you can do
+# FOO=bar,baz and you'll get USE_FOO=bar baz
#
# For each of CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ARGS MAKE_ENV
# ALL_TARGET INSTALL_TARGET USES DISTFILES PLIST_FILES PLIST_DIRS PLIST_DIRSTRY
@@ -383,7 +385,7 @@ PLIST_SUB:= ${PLIST_SUB} ${opt}="@comment "
. if defined(${opt}_USE)
. for option in ${${opt}_USE}
_u= ${option:C/=.*//g}
-USE_${_u:U}+= ${option:C/.*=//g}
+USE_${_u:U}+= ${option:C/.*=//g:C/,/ /g}
. endfor
. endif
. if defined(${opt}_CONFIGURE_ENABLE)