aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2013-09-24 21:01:06 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2013-09-24 21:01:06 +0000
commit7bab335511667ea1f0e539d924dc100663f7bc9b (patch)
treea68b1ab25fb7cc0ef0899abc57b05d6d59fc84ea /Mk/bsd.options.mk
parent080246bc04752150d6181a377a94549c1ca463d2 (diff)
downloadports-7bab335511667ea1f0e539d924dc100663f7bc9b.tar.gz
ports-7bab335511667ea1f0e539d924dc100663f7bc9b.zip
Notes
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 55778a757491..81437ec31f80 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -93,9 +93,9 @@
# ${opt}_CMAKE_OFF When option is disabled, it will add its content to
# the CMAKE_ARGS.
#
-# For each of CFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ENV USES DISTFILES,
-# defining ${opt}_${variable} will add it to the actual variable when the
-# option is enabled.
+# For each of CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ENV USES
+# DISTFILES, defining ${opt}_${variable} will add it to the actual variable
+# when the option is enabled.
#
# For each of the depends target PKG EXTRACT PATCH FETCH BUILD LIB RUN,
# defining ${opt}_${deptype}_DEPENDS will add it to the actual dependency when
@@ -392,7 +392,7 @@ CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ON}
. if defined(${opt}_CMAKE_ON)
CMAKE_ARGS+= ${${opt}_CMAKE_ON}
. endif
-. for flags in CFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ENV USES DISTFILES
+. for flags in CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ENV USES DISTFILES
. if defined(${opt}_${flags})
${flags}+= ${${opt}_${flags}}
. endif