aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-05 17:21:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-05 17:21:32 +0000
commit7ccb78414ddf48eeafcc6bc7ff4c6640d1ff2a64 (patch)
tree6d1ab7f4049c691f2b053ae5b310b063ef0c04fd /Mk/bsd.options.mk
parent7b699592ed81af5e390db8ec1c2fd6a60665f138 (diff)
downloadports-7ccb78414ddf48eeafcc6bc7ff4c6640d1ff2a64.tar.gz
ports-7ccb78414ddf48eeafcc6bc7ff4c6640d1ff2a64.zip
Notes
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 7464141a5a60..34fd0845e99d 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -157,6 +157,29 @@ OPTIONS_GROUP_${group}:= ${OPTIONS_GROUP_${group}:N${opt}}
. endfor
.endfor
+# Remove empty SINGLE/GROUP/RADIO/MULTI
+# Can be empty because of exclude/slaves
+.for single in ${OPTIONS_SINGLE}
+.if empty(OPTIONS_SINGLE_${single})
+OPTIONS_SINGLE:= ${OPTIONS_SINGLE:N${single}}
+.endif
+.endfor
+.for radio in ${OPTIONS_RADIO}
+.if empty(OPTIONS_RADIO_${radio})
+OPTIONS_RADIO:= ${OPTIONS_RADIO:N${radio}}
+.endif
+.endfor
+.for group in ${OPTIONS_GROUP}
+.if empty(OPTIONS_GROUP_${group})
+OPTIONS_GROUP:= ${OPTIONS_GROUP:N${group}}
+.endif
+.endfor
+.for multi in ${OPTIONS_MULTI}
+.if empty(OPTIONS_MULTI_${multi})
+OPTIONS_MULTI:= ${OPTIONS_MULTI:N${multi}}
+.endif
+.endfor
+
# complete list
COMPLETE_OPTIONS_LIST= ${ALL_OPTIONS}
.for single in ${OPTIONS_SINGLE}