aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-04 10:03:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-04 10:03:23 +0000
commit5349651bad6c66058cc9f7ab89f450747a2fcdba (patch)
treee8237cdc87d94b1cf77dea83b678028cade6a14c /Mk/bsd.options.mk
parentd6a6fdb2d97b3d1a73049bed705b29f486692f21 (diff)
downloadports-5349651bad6c66058cc9f7ab89f450747a2fcdba.tar.gz
ports-5349651bad6c66058cc9f7ab89f450747a2fcdba.zip
Notes
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk17
1 files changed, 7 insertions, 10 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 6dd36ce14c7c..28886a6edd8d 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -93,17 +93,14 @@
# ${opt}_CMAKE_OFF When option is disabled, it will add its content to
# the CMAKE_ARGS.
#
-# ${opt}_EXTRA_PATCHES When option is enabled, it will add its content to
-# EXTRA_PATCHES
-#
# For each of CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ARGS MAKE_ENV
-# USES DISTFILES PLIST_FILES PLIST_DIRS PLIST_DIRSTRY EXTRA_PATCHES
-# PATCHFILES PATCH_SITES, defining
-# ${opt}_${variable} will add it to the actual variable when the option is enabled.
+# ALL_TARGET INSTALL_TARGET USES DISTFILES PLIST_FILES PLIST_DIRS PLIST_DIRSTRY
+# EXTRA_PATCHES PATCHFILES PATCH_SITES CATEGORIES, defining ${opt}_${variable}
+# will add its content to the actual variable when the option is enabled.
#
# For each of the depends target PKG EXTRACT PATCH FETCH BUILD LIB RUN,
-# defining ${opt}_${deptype}_DEPENDS will add it to the actual dependency when
-# the option is enabled.
+# defining ${opt}_${deptype}_DEPENDS will add its content to the actual
+# dependency when the option is enabled.
##
# Set all the options available for the ports, beginning with the
@@ -397,8 +394,8 @@ CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ON}
CMAKE_ARGS+= ${${opt}_CMAKE_ON}
. endif
. for flags in CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ARGS MAKE_ENV \
- USES DISTFILES PLIST_FILES PLIST_DIRS PLIST_DIRSTRY \
- EXTRA_PATCHES PATCHFILES PATCH_SITES
+ ALL_TARGET INSTALL_TARGET USES DISTFILES PLIST_FILES PLIST_DIRS PLIST_DIRSTRY \
+ EXTRA_PATCHES PATCHFILES PATCH_SITES CATEGORIES
. if defined(${opt}_${flags})
${flags}+= ${${opt}_${flags}}
. endif