aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-14 13:41:37 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-14 13:41:37 +0000
commit67cfdf9034f9ee7b936adaf1be0cc08a4e538f60 (patch)
tree36b000a218f2de0d60ae75e8e03a7ad2e6956074 /Mk/bsd.options.mk
parent2123bfe614188a1b6d6698fdd5dd1c9702857777 (diff)
downloadports-67cfdf9034f9ee7b936adaf1be0cc08a4e538f60.tar.gz
ports-67cfdf9034f9ee7b936adaf1be0cc08a4e538f60.zip
Notes
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk44
1 files changed, 43 insertions, 1 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index d6def746772c..8f6d3666a8d1 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -287,5 +287,47 @@ WITH_${opt}:= true
. endif
.endif
.endfor
-.endif
###
+
+.for opt in ${COMPLETE_OPTIONS_LIST}
+# PLIST_SUB
+PLIST_SUB?=
+. if defined(OPTIONS_SUB)
+. if ! ${PLIST_SUB:M${opt}=*}
+. if ${PORT_OPTIONS:M${opt}}
+PLIST_SUB:= ${PLIST_SUB} ${opt}=""
+. else
+PLIST_SUB:= ${PLIST_SUB} ${opt}="@comment "
+. endif
+. endif
+. endif
+
+. if ${PORT_OPTIONS:M${opt}}
+. if defined(${opt}_CONFIGURE_ENABLE)
+CONFIGURE_ARGS+= --enable-${${opt}_CONFIGURE_ENABLE}
+. endif
+. if defined(${opt}_CONFIGURE_ON)
+CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ON}
+. endif
+. for flags in CFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ENV USES DISTFILES
+. if defined(${opt}_${flags})
+${flags}+= ${${opt}_${flags}}
+. endif
+. endfor
+. for deptype in PKG EXTRACT PATCH FETCH BUILD LIB RUN
+. if defined(${opt}_${deptype}_DEPENDS)
+${deptype}_DEPENDS+= ${${opt}_${deptype}_DEPENDS}
+. endif
+. endfor
+. else
+. if defined(${opt}_CONFIGURE_ENABLE)
+CONFIGURE_ARGS+= --disable-${${opt}_CONFIGURE_ENABLE}
+. endif
+. if defined(${opt}_CONFIGURE_OFF)
+CONFIGURE_ARGS+= ${${opt}_CONFIGURE_OFF}
+. endif
+. endif
+.endfor
+
+
+.endif