aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.perl.mk
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2012-06-30 21:00:43 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2012-06-30 21:00:43 +0000
commit35338305501ce9c34d2a0d71f5492833d011828a (patch)
tree9b51f3df25919ddc5bb6b8ed0cb84dddf372916b /Mk/bsd.perl.mk
parent7208355bcee850e064a44d64e5ccf4e0f9b16d3f (diff)
downloadports-35338305501ce9c34d2a0d71f5492833d011828a.tar.gz
ports-35338305501ce9c34d2a0d71f5492833d011828a.zip
Notes
Diffstat (limited to 'Mk/bsd.perl.mk')
-rw-r--r--Mk/bsd.perl.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/Mk/bsd.perl.mk b/Mk/bsd.perl.mk
index 77248696865b..541c4f34fa06 100644
--- a/Mk/bsd.perl.mk
+++ b/Mk/bsd.perl.mk
@@ -44,7 +44,7 @@
Perl_Pre_Include= bsd.perl.mk
PERL_Include_MAINTAINER= perl@FreeBSD.org
-PERL_VERSION?= 5.12.4
+PERL_VERSION?= 5.14.2
.if !defined(PERL_LEVEL) && defined(PERL_VERSION)
perl_major= ${PERL_VERSION:C|^([1-9]+).*|\1|}
@@ -66,7 +66,9 @@ PERL_ARCH?= mach
# there must always be a default to prevent dependency failures such
# as "ports/lang: not found"
-.if ${PERL_LEVEL} >= 501400
+.if ${PERL_LEVEL} >= 501600
+PERL_PORT?= perl5.16
+.elif ${PERL_LEVEL} >= 501400
PERL_PORT?= perl5.14
.elif ${PERL_LEVEL} >= 501200
PERL_PORT?= perl5.12
@@ -118,7 +120,7 @@ masked_PERL_LEVEL= ${PERL_LEVEL}
.if ${want_perl_sign} == "+"
.if ${USE_PERL5_LEVEL} > ${masked_PERL_LEVEL}
-USE_PERL5_REASON?= requires Perl ${want_perl_ver} or later, install lang/perl5.8, lang/perl5.10, lang/perl5.12 or lang/perl5.14 and try again
+USE_PERL5_REASON?= requires Perl ${want_perl_ver} or later, install lang/perl${want_perl_major}.${want_perl_minor:C|^0||} and try again
IGNORE= ${USE_PERL5_REASON}
.endif # ${USE_PERL5_LEVEL} > ${masked_PERL_LEVEL}
.elif ${want_perl_sign} == ""