aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.perl.mk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-26 00:15:26 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-26 00:15:26 +0000
commitc7735b8048091d9c02d14d345a89ef1f999180f9 (patch)
treee7907fb0996f254ee9555f121fce2f8980064312 /Mk/bsd.perl.mk
parenta78edad482d6040ca8901deffa3dc857e4bd15e1 (diff)
downloadports-c7735b8048091d9c02d14d345a89ef1f999180f9.tar.gz
ports-c7735b8048091d9c02d14d345a89ef1f999180f9.zip
Notes
Diffstat (limited to 'Mk/bsd.perl.mk')
-rw-r--r--Mk/bsd.perl.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/bsd.perl.mk b/Mk/bsd.perl.mk
index 6319b24286d1..c8a0e1651e3f 100644
--- a/Mk/bsd.perl.mk
+++ b/Mk/bsd.perl.mk
@@ -73,6 +73,8 @@
# port. The version requirement can be specified
# here, as well.
#
+# WANT_PERL5 - Set this is your port conditionally depends on Perl.
+# This MUST appear before the inclusion of bsd.port.pre.mk.
.if !defined(_POSTMKINCLUDED) && !defined(Perl_Pre_Include)
@@ -182,6 +184,10 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
.endif # defined(_PERL_REFACTORING_COMPLETE)
+.if !defined(PERL) || !defined(PERL5) || !defined(PERL_PORT) || !defined(PERL_VERSION)
+IGNORE= missing define for WANT_PERL, USE_PERL5, or similar before bsd.port.pre.mk inclusion
+.endif
+
.if defined(PERL_MODBUILD)
PERL_CONFIGURE= yes
CONFIGURE_SCRIPT?= Build.PL