aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.perl.mk
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-03-05 17:56:24 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-03-05 17:56:24 +0000
commit0f24c25f5a0f3e0fc1eba0df35f8fe4234aa23bd (patch)
treebceb2742d39fdcf46634bb4aa705a8a439a58bfe /Mk/bsd.perl.mk
parentcf30e6a4d302b5a5be5e545ba263d39c2fc5a567 (diff)
downloadports-0f24c25f5a0f3e0fc1eba0df35f8fe4234aa23bd.tar.gz
ports-0f24c25f5a0f3e0fc1eba0df35f8fe4234aa23bd.zip
Notes
Diffstat (limited to 'Mk/bsd.perl.mk')
-rw-r--r--Mk/bsd.perl.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/Mk/bsd.perl.mk b/Mk/bsd.perl.mk
index ce142278ad34..2897951d8fe6 100644
--- a/Mk/bsd.perl.mk
+++ b/Mk/bsd.perl.mk
@@ -17,7 +17,6 @@
# installed from a port, but without the version number.
# Use this if you need to replace "#!" lines in scripts.
# PERL_VERSION - Full version of perl5 (see below for current value).
-# PERL_VER - Short version of perl5 (see below for current value).
# PERL_LEVEL - Perl version as an integer of the form MNNNPP, where
# M is major version, N is minor version, and P is
# the patch level. E.g., PERL_VERSION=5.6.1 would give
@@ -86,7 +85,6 @@ PERL_Include_MAINTAINER= perl@FreeBSD.org
.if defined(_PERL_REFACTORING_COMPLETE)
PERL_VERSION?= 5.8.9
-PERL_VER?= 5.8.9
.if !defined(PERL_LEVEL) && defined(PERL_VERSION)
perl_major= ${PERL_VERSION:C|\..*||}
@@ -107,7 +105,7 @@ PERL_PORT?= perl5.8
PERL_PORT?= perl5.6
.endif
-SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
+SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VERSION}
SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
PERL5= ${LOCALBASE}/bin/perl${PERL_VERSION}
@@ -178,7 +176,7 @@ Perl_Post_Include= bsd.perl.mk
.if defined(_PERL_REFACTORING_COMPLETE)
PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
- PERL_VER=${PERL_VER} \
+ PERL_VER=${PERL_VERSION} \
PERL_ARCH=${PERL_ARCH} \
SITE_PERL=${SITE_PERL_REL}