aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.php.mk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-07-05 02:18:09 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-07-05 02:18:09 +0000
commite2d64eefa615da78a7422ba3138dc59b63977201 (patch)
tree669f512f039d1cfcaedb6d0eb84b04a026e6dad7 /Mk/bsd.php.mk
parent30fc425b564a926e65aed480a73762a98c707557 (diff)
downloadports-e2d64eefa615da78a7422ba3138dc59b63977201.tar.gz
ports-e2d64eefa615da78a7422ba3138dc59b63977201.zip
Notes
Diffstat (limited to 'Mk/bsd.php.mk')
-rw-r--r--Mk/bsd.php.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index 5104f0a51e6b..58c409fd410f 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -18,7 +18,7 @@
# The port can set these options in its Makefile before bsd.ports.pre.mk:
#
# DEFAULT_PHP_VER=N - Use PHP version N if PHP is not yet installed.
-# BROKEN_WITH_PHP=N - The port doesn't work with PHP version N.
+# IGNORE_WITH_PHP=N - The port doesn't work with PHP version N.
# USE_PHPIZE=yes - Use to build a PHP extension.
# USE_PHPEXT=yes - Use to build, install and register a PHP extension.
# USE_PHP_BUILD=yes - Set PHP also as a build dependency.
@@ -70,10 +70,14 @@ PHP_SAPI?= ""
.endif
PHP_EXT_INC?= ""
+# compatability shim
.if defined(BROKEN_WITH_PHP)
-. for VER in ${BROKEN_WITH_PHP}
+IGNORE_WITH_PHP=${BROKEN_WITH_PHP}
+.endif
+.if defined(IGNORE_WITH_PHP)
+. for VER in ${IGNORE_WITH_PHP}
. if ${PHP_VER} == "${VER}"
-BROKEN= Doesn't work with PHP version : ${PHP_VER} (Doesn't support PHP ${BROKEN_WITH_PHP})
+IGNORE= cannot install: doesn't work with PHP version : ${PHP_VER} (Doesn't support PHP ${IGNORE_WITH_PHP})
. endif
. endfor
.endif