aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-08 13:34:24 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-08 13:34:24 +0000
commit5dd54c7ca6e121e46f32c767d13c0052fd65de69 (patch)
treee97df762ceb928f3cccc6e1765b5c1ee39865e2f /Mk/bsd.port.mk
parent5a5f87203b7f341d5dc7ba9c5692da68452a0100 (diff)
downloadports-5dd54c7ca6e121e46f32c767d13c0052fd65de69.tar.gz
ports-5dd54c7ca6e121e46f32c767d13c0052fd65de69.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk18
1 files changed, 9 insertions, 9 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1f581a1e7154..fb3f78abae5f 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1543,15 +1543,6 @@ check-makefile::
_POSTMKINCLUDED= yes
-# Loading features
-.for f in ${_USES_POST}
-_f=${f:C/\:.*//g}
-.if ${_f} != ${f}
-${_f}_ARGS:= ${f:C/^[^\:]*\://g}
-.endif
-.include "${USESDIR}/${_f}.mk"
-.endfor
-
WRKDIR?= ${WRKDIRPREFIX}${.CURDIR}/work
.if !defined(IGNORE_MASTER_SITE_GITHUB) && defined(USE_GITHUB)
WRKSRC?= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}
@@ -2051,6 +2042,15 @@ RUN_DEPENDS+= ${_GL_${_component}_RUN_DEPENDS}
USE_SUBMAKE= yes
.endif
+# Loading features
+.for f in ${_USES_POST}
+_f=${f:C/\:.*//g}
+.if ${_f} != ${f}
+${_f}_ARGS:= ${f:C/^[^\:]*\://g}
+.endif
+.include "${USESDIR}/${_f}.mk"
+.endfor
+
.if defined(USE_XORG)
# Add explicit X options to avoid problems with false positives in configure
.if defined(GNU_CONFIGURE)