aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2015-10-12 22:28:15 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2015-10-12 22:28:15 +0000
commitc46779db54570cae2fcac43394c37b04576d6aa6 (patch)
treeb6cadc188a75e7d1631a43e73460cbfd0eaff910 /Mk/bsd.port.mk
parent1c65a7751e9f66c1523c0741bd297f3af5a71cc9 (diff)
downloadports-c46779db54570cae2fcac43394c37b04576d6aa6.tar.gz
ports-c46779db54570cae2fcac43394c37b04576d6aa6.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index e37865b3b0ac..9a57be8b4041 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1675,6 +1675,7 @@ HAVE_COMPAT_IA32_KERN!= if ${SYSCTL} -n compat.ia32.maxvmem >/dev/null 2>&1; the
.endif
.endif
.endif
+_EXPORTED_VARS+= HAVE_COMPAT_IA32_KERN
.if defined(IA32_BINARY_PORT) && ${ARCH} != "i386"
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
@@ -5061,7 +5062,8 @@ ${_t}:
.if !defined(NOPRECIOUSMAKEVARS)
# These won't change, so we can pass them through the environment
.for var in ${_EXPORTED_VARS}
-.if empty(.MAKEFLAGS:M${var}=*)
+.if empty(.MAKEFLAGS:M${var}=*) && !empty(${var})
+.warning exporting ${var}
.MAKEFLAGS: ${var}=${${var}:Q}
.endif
.endfor