aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-28 16:36:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-28 16:36:31 +0000
commitfe837ee6c691d6b779351981a17ce6cacf012498 (patch)
treeaeb03f1aa94222d62e9cdc28c4130adb5b0e5327 /Mk/bsd.port.mk
parentfe60cb457cdab630d67a06be5bf1e9c5afc4fc6e (diff)
downloadports-fe837ee6c691d6b779351981a17ce6cacf012498.tar.gz
ports-fe837ee6c691d6b779351981a17ce6cacf012498.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk20
1 files changed, 12 insertions, 8 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index b74a75b2db41..06e8f3521332 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1493,11 +1493,13 @@ QA_ENV+= USESSHAREDMIMEINFO=yes
# Loading features
.for f in ${USES}
-_f=${f:C/\:.*//g}
-.if ${_f} != ${f}
-${_f}_ARGS:= ${f:C/^[^\:]*\://g}
+_f:= ${f:C/\:.*//}
+.if !defined(${_f}_ARGS)
+${_f}_ARGS:= ${f:C/^[^\:]*(\:|\$)//:S/,/ /g}
.endif
-.include "${USESDIR}/${_f}.mk"
+.endfor
+.for f in ${USES}
+.include "${USESDIR}/${f:C/\:.*//}.mk"
.endfor
.if defined(USE_BZIP2)
@@ -1917,11 +1919,13 @@ USE_SUBMAKE= yes
# Loading features
.for f in ${_USES_POST}
-_f=${f:C/\:.*//g}
-.if ${_f} != ${f}
-${_f}_ARGS:= ${f:C/^[^\:]*\://g}
+_f:= ${f:C/\:.*//}
+.if !defined(${_f}_ARGS)
+${_f}_ARGS:= ${f:C/^[^\:]*(\:|\$)//:S/,/ /g}
.endif
-.include "${USESDIR}/${_f}.mk"
+.endfor
+.for f in ${_USES_POST}
+.include "${USESDIR}/${f:C/\:.*//}.mk"
.endfor
.if defined(USE_XORG)