aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-03-05 17:56:24 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-03-05 17:56:24 +0000
commit0f24c25f5a0f3e0fc1eba0df35f8fe4234aa23bd (patch)
treebceb2742d39fdcf46634bb4aa705a8a439a58bfe /Mk/bsd.port.mk
parentcf30e6a4d302b5a5be5e545ba263d39c2fc5a567 (diff)
downloadports-0f24c25f5a0f3e0fc1eba0df35f8fe4234aa23bd.tar.gz
ports-0f24c25f5a0f3e0fc1eba0df35f8fe4234aa23bd.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 992186d16e69..839966dab118 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -327,7 +327,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# installed from a port, but without the version number.
# Use this if you need to replace "#!" lines in scripts.
# PERL_VERSION - Full version of perl5 (see below for current value).
-# PERL_VER - Short version of perl5 (see below for current value).
# PERL_LEVEL - Perl version as an integer of the form MNNNPP, where
# M is major version, N is minor version, and P is
# the patch level. E.g., PERL_VERSION=5.6.1 would give
@@ -1408,7 +1407,6 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
.if !defined(_PERL_REFACTORING_COMPLETE)
PERL_VERSION?= 5.8.9
-PERL_VER?= 5.8.9
.if !defined(PERL_LEVEL) && defined(PERL_VERSION)
perl_major= ${PERL_VERSION:C|^([1-9]+).*|\1|}
@@ -1434,7 +1432,7 @@ PERL_PORT?= perl5.8
PERL_PORT?= perl5.6
.endif
-SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
+SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VERSION}
SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
PERL5= ${LOCALBASE}/bin/perl${PERL_VERSION}
@@ -1920,7 +1918,7 @@ IGNORE= uses unknown USE_BISON construct
.if !defined(_PERL_REFACTORING_COMPLETE)
PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
- PERL_VER=${PERL_VER} \
+ PERL_VER=${PERL_VERSION} \
PERL_ARCH=${PERL_ARCH} \
SITE_PERL=${SITE_PERL_REL}
.endif # !defined(_PERL_REFACTORING_COMPLETE)