aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-08-28 13:50:43 +0000
committerJohn Marino <marino@FreeBSD.org>2015-08-28 13:50:43 +0000
commit5f3bf8cb9de245f30e570834f1e9440ed6175db0 (patch)
treeee2b75e4b661c4753c33b680a7ec4897130caba0 /Mk/bsd.port.mk
parente638299edcfecb35838ad7fad0b71c4fa5ed7639 (diff)
downloadports-5f3bf8cb9de245f30e570834f1e9440ed6175db0.tar.gz
ports-5f3bf8cb9de245f30e570834f1e9440ed6175db0.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 4c71f602791a..db6d446f0658 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1024,6 +1024,10 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# has been specified in distinfo. This is useful
# when using an alternate FETCH_CMD.
#
+# PKG_CREATE_VERBOSE - If set, pass the -v option to pkg create which
+# ensures periodic output during packaging and
+# will help prevent timeouts by build monitors
+#
# End of the list of all variables that need to be defined in a port.
# Most port authors should not need to understand anything after this point.
#
@@ -3453,6 +3457,9 @@ do-install:
.if !target(do-package)
PKG_CREATE_ARGS= -r ${STAGEDIR} -m ${METADIR} -p ${TMPPLIST}
+.if defined(PKG_CREATE_VERBOSE)
+PKG_CREATE_ARGS+= -v
+.endif
do-package: create-manifest
do-package: ${TMPPLIST}
@if [ -d ${PACKAGES} ]; then \