aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2009-06-11 09:09:29 +0000
committerErwin Lansing <erwin@FreeBSD.org>2009-06-11 09:09:29 +0000
commitfb967c21c1506516b3d244c18fe97873fac06651 (patch)
tree155b36a36e24df73cf9bd77ecbdba999fcda00e2 /Mk/bsd.port.mk
parent4934894ccc528a84b3660b236892b84a7aba42fb (diff)
downloadports-fb967c21c1506516b3d244c18fe97873fac06651.tar.gz
ports-fb967c21c1506516b3d244c18fe97873fac06651.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 9540f4008545..8e64eac9b5e4 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1309,6 +1309,19 @@ WITHOUT_${W}:= true
DOS2UNIX_REGEX?= .*
+# At least KDE needs TMPDIR for the package building,
+# so we're setting it to the known default value.
+.if defined(PACKAGE_BUILDING)
+TMPDIR?= /tmp
+.endif # defined(PACKAGE_BUILDING)
+
+# Respect TMPDIR passed via make.conf or similar and pass it down
+# to configure and make.
+.if defined(TMPDIR)
+MAKE_ENV+= TMPDIR="${TMPDIR}"
+CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
+.endif # defined(TMPDIR)
+
# Start of pre-makefile section.
.if !defined(AFTERPORTMK) && !defined(INOPTIONSMK)