aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-25 12:24:10 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-25 12:24:10 +0000
commit4b653b49e1abf572842e05fcf9c12d44a39e1858 (patch)
treee5440ad6a526eb296063000d16637e87751c474d /Mk/bsd.port.mk
parentd8b6513e944fabb5f1e02937a05e849ef2319fd3 (diff)
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0535896ef1c0..252c9faea92a 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1628,6 +1628,10 @@ PATCH_DEPENDS+= ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
.endif
.endif
+.if !defined(UID)
+UID!= ${ID} -u
+.endif
+
# Check the compatibility layer for amd64/ia64
.if ${ARCH} == "amd64" || ${ARCH} =="ia64"
@@ -2308,9 +2312,6 @@ MTREE_ARGS?= -U ${MTREE_FOLLOWS_SYMLINKS} -f ${MTREE_FILE} -d -e -p
READLINK_CMD?= /usr/bin/readlink
# Determine whether or not we can use rootly owner/group functions.
-.if !defined(UID)
-UID!= ${ID} -u
-.endif
.if ${UID} == 0
_BINOWNGRP= -o ${BINOWN} -g ${BINGRP}
_SHROWNGRP= -o ${SHAREOWN} -g ${SHAREGRP}