aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorEd Maste <emaste@FreeBSD.org>2018-09-18 14:48:48 +0000
committerEd Maste <emaste@FreeBSD.org>2018-09-18 14:48:48 +0000
commit635e6cc2e3f343d3970ed82bd55469234faaaadc (patch)
treeeb714b6159c7c511c1f29417bdc1398e0953e472 /Mk/bsd.port.mk
parent1bc9d18ba61eafe2c837fb9539a95c086c0581f4 (diff)
downloadports-635e6cc2e3f343d3970ed82bd55469234faaaadc.tar.gz
ports-635e6cc2e3f343d3970ed82bd55469234faaaadc.zip
Hoist LDFLAGS_${ARCH} logic into bsd.port.mk
Approved by: portmgr (bapt) Sponsored by: The FreeBSD Foundation
Notes
Notes: svn path=/head/; revision=480026
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 688a38c2cdd2..c8e1008a5c81 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -363,6 +363,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# CXXFLAGS_${ARCH}
# Append the cxxflags to CXXFLAGS only on the specified architecture
##
+# LDFLAGS_${ARCH} Append the ldflags to LDFLAGS only on the specified architecture
# USE_SDL - If set, this port uses the sdl libraries.
# See bsd.sdl.mk for more information.
##
@@ -2050,6 +2051,10 @@ ${lang}FLAGS+= ${${lang}FLAGS_${ARCH}}
.endif
.endfor
+.if defined(LDFLAGS_${ARCH})
+LDFLAGS+= ${LDFLAGS_${ARCH}}
+.endif
+
# Multiple make jobs support
.if defined(DISABLE_MAKE_JOBS) || defined(MAKE_JOBS_UNSAFE)
_MAKE_JOBS?= #