aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2017-06-18 18:09:16 +0000
committerDavid Naylor <dbn@FreeBSD.org>2017-06-18 18:09:16 +0000
commit9920d3ae657e820bce42911009136fc059210d0d (patch)
tree237480885bd130394dbcbc56f765540bba4416e2 /Mk/bsd.port.mk
parent4aeae92375bb57620d054d3cc88677ebba4f22bf (diff)
downloadports-9920d3ae657e820bce42911009136fc059210d0d.tar.gz
ports-9920d3ae657e820bce42911009136fc059210d0d.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bb6b1995585c..42546f7f8578 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -226,6 +226,10 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
#
# NO_ARCH - Set this if port is architecture neutral.
#
+# NO_ARCH_IGNORE - Set this to a list files to ignore when NO_ARCH is checked
+# in stage-qa (i.e. architecture specific files that are
+# 'bundled' with the port).
+#
# Set these if your port only makes sense to certain architectures.
# They are lists containing names for them (e.g., "amd64 i386").
# (Defaults: not set.)
@@ -1527,7 +1531,9 @@ QA_ENV+= STAGEDIR=${STAGEDIR} \
PKGORIGIN=${PKGORIGIN} \
LIB_RUN_DEPENDS='${_LIB_RUN_DEPENDS:C,[^:]*:([^:]*):?.*,\1,}' \
UNIFIED_DEPENDS=${_UNIFIED_DEPENDS:C,([^:]*:[^:]*):?.*,\1,:O:u:Q} \
- PKGBASE=${PKGBASE}
+ PKGBASE=${PKGBASE} \
+ NO_ARCH=${NO_ARCH} \
+ "NO_ARCH_IGNORE=${NO_ARCH_IGNORE}"
.if !empty(USES:Mssl)
QA_ENV+= USESSSL=yes
.endif