aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-15 16:45:47 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-15 16:45:47 +0000
commit911c27a74b0cec37b90df5fb2148ae41c9601970 (patch)
tree19ce9c460b80ec43f987cc901656d2e47f90ef50 /Mk/bsd.port.mk
parentbe3b808c2a7997ee5e62125f1f1edbde1c6b2554 (diff)
r314316 loads the features a bit too late it should be done prior to the path sanity checking
Reported by: bdrewery
Notes
Notes: svn path=/head/; revision=314317
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk18
1 files changed, 9 insertions, 9 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index d1a9754d0a9d..8280916e6b19 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1510,6 +1510,15 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
.include "${PORTSDIR}/Mk/bsd.pbi.mk"
+# Loading features
+.for f in ${USES}
+_f=${f:C/\:.*//g}
+.if ${_f} != ${f}
+${_f}_ARGS:= ${f:C/^[^\:]*\://g}
+.endif
+.include "${USESDIR}/${_f}.mk"
+.endfor
+
# You can force skipping these test by defining IGNORE_PATH_CHECKS
.if !defined(IGNORE_PATH_CHECKS)
.if (${PREFIX:C,(^.).*,\1,} != "/")
@@ -1527,15 +1536,6 @@ CD_MOUNTPTS?= /cdrom ${CD_MOUNTPT}
WWWOWN?= www
WWWGRP?= www
-# Loading features
-.for f in ${USES}
-_f=${f:C/\:.*//g}
-.if ${_f} != ${f}
-${_f}_ARGS:= ${f:C/^[^\:]*\://g}
-.endif
-.include "${USESDIR}/${_f}.mk"
-.endfor
-
.endif
# End of pre-makefile section.