aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-12-17 13:01:59 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-12-17 13:01:59 +0000
commit214e08275503a4720c380c0d5209822c79024a85 (patch)
tree0e6fb9f527959d3f61a3720b9b9907f78e3cee14 /Mk/bsd.port.mk
parent2efcdc99a9b2fddeba54d6f1bee57cfee497f858 (diff)
downloadports-214e08275503a4720c380c0d5209822c79024a85.tar.gz
ports-214e08275503a4720c380c0d5209822c79024a85.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 1 insertions, 7 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index cc39e9d47adb..5d5613ce5e23 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3033,12 +3033,6 @@ build: configure
@${TOUCH} ${TOUCH_FLAGS} ${BUILD_COOKIE}
.endif
-# Disable install
-.if defined(NO_INSTALL) && !target(do-install)
-do-install:
- @${DO_NADA}
-.endif
-
# Disable package
.if defined(NO_PACKAGE) && !target(package)
package:
@@ -3561,7 +3555,7 @@ check-install-conflicts:
# Install
-.if !target(do-install)
+.if !target(do-install) && !defined(NO_INSTALL)
do-install:
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
.endif