aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2011-04-24 15:37:53 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2011-04-24 15:37:53 +0000
commitaaa59c1b11e58d2aee70752d85260c56524f930d (patch)
treee9e7cfb5e95917566fefebbb8187936e6b7845e5 /Mk/bsd.port.mk
parenta18e391e076f29d37e0f8c2e7000e78be0115831 (diff)
Mk/bsd.apache.mk was rewritten with a new logic and some new parameters
to support future apache versions and the transition to apache22. Existing and new USE_APACHE* parameters: USE_APACHE set apache and apxs as build and run dependency USE_APACHE_BUILD set apache and apxs as build dependency USE_APACHE_RUN set apache and apxs as run dependency The following example is representative of all three possible parameters to use: USE_APACHE= 22 specify exact version USE_APACHE= 1.3+ specify [min] version, no [max] version USE_APACHE= 13-22 specify [min]-[max] range USE_APACHE= -2.2 specify [max] version, no [min] version Values can be specified with and without "." (dot) between major and minor version numbers. For example 22 is equal to 2.2 For documentation and full changelist please take a look into Mk/bsd.apache.mk or http://wiki.freebsd.org/bsd.apache.mk Commit with hat apache@ PR: ports/156533 Submitted by: ohauer
Notes
Notes: svn path=/head/; revision=273137
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index cfd6c1fd64bd..34ba21864c0f 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1536,7 +1536,7 @@ PERL= ${LOCALBASE}/bin/perl
.include "${PORTSDIR}/Mk/bsd.tcl.mk"
.endif
-.if defined(USE_APACHE)
+.if defined(USE_APACHE) || defined(USE_APACHE_BUILD) || defined(USE_APACHE_RUN)
.include "${PORTSDIR}/Mk/bsd.apache.mk"
.endif
@@ -2135,7 +2135,7 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
.include "${PORTSDIR}/Mk/bsd.wx.mk"
.endif
-.if defined(USE_APACHE) || defined(APACHE_COMPAT)
+.if defined(USE_APACHE) || defined(USE_APACHE_BUILD) || defined(USE_APACHE_RUN)
.include "${PORTSDIR}/Mk/bsd.apache.mk"
.endif