aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-03 08:14:43 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-03 08:14:43 +0000
commitdbba8af6447e625aae93ec45e619acbecb4ab189 (patch)
treed696a8c2d3e835a743132aa1f6a5cc0557d1c435 /Mk/bsd.port.mk
parent683eaaa4ff765b627c52f147501abfaec4449cce (diff)
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk18
1 files changed, 4 insertions, 14 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 4a1b18ee67ba..bca063cc3535 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -170,10 +170,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# target.
# USE_X_PREFIX - Says that the port installs in ${X11BASE}. Implies USE_XLIB.
# USE_XLIB - Says that the port uses X libraries.
-# USE_QT - Says that the port uses version 1 of the qt toolkit.
-# Implies USE_NEWGCC.
-# USE_QT2 - Says that the port uses version 2 of the qt toolkit.
-# Implies USE_NEWGCC.
# USE_MOTIF - Says that the port uses the Motif toolkit. Implies USE_XPM.
#
# Dependency checking. Use these if your port requires another port
@@ -764,16 +760,6 @@ MANCOMPRESSED?= yes
MANCOMPRESSED?= no
.endif
-.if defined(USE_QT)
-LIB_DEPENDS+= qt.3:${PORTSDIR}/x11-toolkits/qt145
-USE_NEWGCC= yes
-.endif
-
-.if defined(USE_QT2)
-LIB_DEPENDS+= qt2.4:${PORTSDIR}/x11-toolkits/qt23
-USE_NEWGCC= yes
-.endif
-
.if defined(USE_BZIP2)
BUILD_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
.endif
@@ -904,6 +890,10 @@ LIB_DEPENDS+= X11.6:${PORTSDIR}/x11/XFree86-4-libraries
.endif
.endif
+.if defined(USE_QT) || defined(USE_QT2) || defined(USE_QT_VER) || defined(USE_KDELIBS_VER) || defined(USE_KDEBASE_VER)
+.include "${PORTSDIR}/Mk/bsd.kde.mk"
+.endif
+
.include "${PORTSDIR}/Mk/bsd.gnome.mk"
.if exists(${PORTSDIR}/../Makefile.inc)