aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2007-01-30 04:18:07 +0000
committerKris Kennaway <kris@FreeBSD.org>2007-01-30 04:18:07 +0000
commit1801d62b27475a63728be523be256d5b41c18581 (patch)
treeffe2e3dc464706d987d2124b172890e3e48d990d /Mk/bsd.port.mk
parentb90e75409cd859ed7a4f30e83e3e7c27a1ed4699 (diff)
downloadports-1801d62b27475a63728be523be256d5b41c18581.tar.gz
ports-1801d62b27475a63728be523be256d5b41c18581.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk15
1 files changed, 2 insertions, 13 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 35051165c86b..5a57e0b4303a 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -447,8 +447,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_LINUX - Set to yes to say the port needs the default linux base port.
# Set to value <X>, if the port needs emulators/linux_base-<X>.
# If set to "7", a dependency is registered to emulators/linux_base.
-# Implies appropriate settings for NO_FILTER_SHLIBS,
-# STRIP and STRIP_CMD.
+# Implies appropriate settings for STRIP and STRIP_CMD.
# USE_LINUX_PREFIX
# - controls the action of PREFIX (see above). Only use this
# if the port is a linux infrastructure port (e.g. contains libs
@@ -1152,7 +1151,7 @@ OSVERSION!= ${SYSCTL} -n kern.osreldate
# Get the object format.
.if !defined(PORTOBJFORMAT)
-PORTOBJFORMAT!= ${TEST} -x /usr/bin/objformat && /usr/bin/objformat || ${ECHO_CMD} aout
+PORTOBJFORMAT?= elf
.endif
MASTERDIR?= ${.CURDIR}
@@ -1802,8 +1801,6 @@ STRIP_CMD= ${LINUXBASE}/usr/bin/strip
STRIP_CMD= ${TRUE}
. endif
-NO_FILTER_SHLIBS= yes
-
# Allow the user to specify another linux_base version.
. if defined(OVERRIDE_LINUX_BASE_PORT)
. if ${USE_LINUX:L} == yes
@@ -5461,14 +5458,6 @@ generate-plist:
@${ECHO_CMD} "@unexec ${LDCONFIG} -32 -R || ${TRUE}" >> ${TMPPLIST}
.endif
.endif
-.if !defined(NO_FILTER_SHLIBS)
-.if (${PORTOBJFORMAT} == "aout")
- @${SED} -e 's,\(/lib.*\.so\.[0-9]*\)$$,\1.0,' ${TMPPLIST} > ${TMPPLIST}.tmp
-.else
- @${SED} -e 's,\(/lib.*\.so\.[0-9]*\)\.[0-9]*$$,\1,' ${TMPPLIST} > ${TMPPLIST}.tmp
-.endif
- @${MV} -f ${TMPPLIST}.tmp ${TMPPLIST}
-.endif
.endif
${TMPPLIST}: