aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-24 07:11:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-24 07:11:41 +0000
commit189a4c90996690153c959238e36518cbaa30a913 (patch)
tree480c39ec74b6e0e110bcd3b6951fad45568d9ecd /Mk/bsd.port.mk
parente924662c0897376cc21c3508211950f8400cec92 (diff)
downloadports-189a4c90996690153c959238e36518cbaa30a913.tar.gz
ports-189a4c90996690153c959238e36518cbaa30a913.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk17
1 files changed, 11 insertions, 6 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index d9a9c80e41b1..5dec30e2d56d 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -460,14 +460,19 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_KDELIBS_VER - Set to 3 to use the KDE libraries.
# Implies inclusion of bsd.kde.mk.
#
-# USE_KDE4 - A list of the KDE4 dependencies the port has (e.g.,
+# USE_KDE4 - A list of the KDE4 dependencies the port has (e.g.,
# kdelibs, kdebase). Implies that the port needs KDE.
# Implies inclusion of bsd.kde4.mk. See bsd.kde4.mk
# for more details.
#
-# USE_QT_VER - Set to 3 or 4 to use the respective version
-# of the QT libraries.
-# Implies inclusion of bsd.kde.mk.
+# USE_QT_VER - Set to 3 or 4 to use the respective version
+# of the Qt libraries.
+# Implies inclusion of bsd.kde.mk or bsd.qt.mk.
+#
+# USE_QT4 - A list of the QT4 dependencies the port has (e.g,
+# corelib, webkit). Implies that the port needs Qt.
+# Implies the inclusion of bsd.qt.mk. See bsd.qt.mk
+# for more details.
#
# USE_LINUX - Set to yes to say the port needs the default linux base port.
# Set to value <X>, if the port needs emulators/linux_base-<X>.
@@ -1474,7 +1479,7 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
.include "${PORTSDIR}/Mk/bsd.kde.mk"
.endif
-.if defined (USE_QT_VER) && ${USE_QT_VER:L} == 4
+.if defined(USE_QT_VER) && ${USE_QT_VER:L} == 4 || defined(USE_QT4)
.include "${PORTSDIR}/Mk/bsd.qt.mk"
.endif
@@ -2035,7 +2040,7 @@ IGNORE= uses unknown USE_BISON construct
.include "${PORTSDIR}/Mk/bsd.linux-apps.mk"
.endif
-.if defined (USE_QT_VER) && ${USE_QT_VER:L} == 4
+.if defined(USE_QT_VER) && ${USE_QT_VER:L} == 4 || defined(USE_QT4)
.include "${PORTSDIR}/Mk/bsd.qt.mk"
.endif