aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-30 04:01:39 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-30 04:01:39 +0000
commit64ec019f724c9416df219041447f2de45c46946c (patch)
tree51e8be21a256db876801f86be19b77421075da13 /Mk/bsd.port.mk
parent4cfd5f88de1cd68c8c264abcff0e9fe60f567a17 (diff)
downloadports-64ec019f724c9416df219041447f2de45c46946c.tar.gz
ports-64ec019f724c9416df219041447f2de45c46946c.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 35896f593852..1e149d7c85ae 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4774,6 +4774,10 @@ ${deptype:L}-depends:
.if !defined(NO_DEPENDS)
@for i in `${ECHO_CMD} "${${deptype}_DEPENDS}"`; do \
prog=`${ECHO_CMD} $$i | ${SED} -e 's/:.*//'`; \
+ if [ -z "$$prog" ]; then \
+ ${ECHO_MSG} "Error: there is an empty port dependency in ${deptype}_DEPENDS."; \
+ break; \
+ fi; \
dir=`${ECHO_CMD} $$i | ${SED} -e 's/[^:]*://'`; \
if ${EXPR} "$$dir" : '.*:' > /dev/null; then \
target=`${ECHO_CMD} $$dir | ${SED} -e 's/.*://'`; \