aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-02-11 15:21:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-02-11 15:21:25 +0000
commit14223135a0ec1fc40ededbe70b4ad5ce27bbbf18 (patch)
treedcdd6ddea0d17130f314dcab29a69f1f9cb17244 /Mk/bsd.port.mk
parent16b9cef21a378ed59b9afc55a75f9afa8134dfe3 (diff)
downloadports-14223135a0ec1fc40ededbe70b4ad5ce27bbbf18.tar.gz
ports-14223135a0ec1fc40ededbe70b4ad5ce27bbbf18.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk15
1 files changed, 5 insertions, 10 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 6e41f31237d5..8f3b4d3d79e1 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -364,8 +364,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# Append the cxxflags to CXXFLAGS only on the specified architecture
##
# LDFLAGS_${ARCH} Append the ldflags to LDFLAGS only on the specified architecture
-# USE_SDL - If set, this port uses the sdl libraries.
-# See bsd.sdl.mk for more information.
##
# USE_OPENLDAP - If set, this port uses the OpenLDAP libraries.
# Implies: WANT_OPENLDAP_VER?=24
@@ -1425,6 +1423,11 @@ DEV_WARNING+= "Using USE_GL alone is deprecated, please add USES=gl."
USES+= gl
.endif
+.if defined(USE_SDL) && (!defined(USES) || !${USES:Msdl})
+DEV_WARNING+= "Using USE_SDL alone is deprecated, please add USES=sdl."
+USES+= sdl
+.endif
+
.if defined(USE_MYSQL)
USE_MYSQL:= ${USE_MYSQL:N[yY][eE][sS]:Nclient}
.if defined(WANT_MYSQL_VER)
@@ -1445,10 +1448,6 @@ USES+=mysql:${USE_MYSQL}
.include "${PORTSDIR}/Mk/bsd.gstreamer.mk"
.endif
-.if defined(USE_SDL)
-.include "${PORTSDIR}/Mk/bsd.sdl.mk"
-.endif
-
.if !defined(UID)
UID!= ${ID} -u
.endif
@@ -1944,10 +1943,6 @@ _FORCE_POST_PATTERNS= rmdir kldxref mkfontscale mkfontdir fc-cache \
.include "${PORTSDIR}/Mk/bsd.ocaml.mk"
.endif
-.if defined(USE_SDL)
-.include "${PORTSDIR}/Mk/bsd.sdl.mk"
-.endif
-
.if defined(USE_PHP) && (!defined(USES) || ( defined(USES) && !${USES:Mphp*} ))
DEV_WARNING+= "Using USE_PHP alone is deprecated, please use USES=php"
_USES_POST+= php