aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-09-19 00:50:37 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-09-19 00:50:37 +0000
commit2e0063b2c343f0e69fd5487fce35e42e4b76f85e (patch)
tree644cf5b02dc7c7393899fde25e48b3e113f7cca0 /Mk/bsd.port.mk
parentb021067d57f4fa008fe5e0e0743446efc7e307c5 (diff)
downloadports-2e0063b2c343f0e69fd5487fce35e42e4b76f85e.tar.gz
ports-2e0063b2c343f0e69fd5487fce35e42e4b76f85e.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 89b42bda85c1..526f925229f8 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1223,9 +1223,9 @@ WITH_NEW_XORG?= yes
.if !defined(_PKG_VERSION)
_PKG_VERSION!= ${PKG_BIN} -v
.endif
-_PKG_STATUS!= ${PKG_BIN} version -t ${_PKG_VERSION:S/-/\./g} ${MINIMAL_PKG_VERSION}
+_PKG_STATUS!= ${PKG_BIN} version -t ${_PKG_VERSION:C/-.*//g} ${MINIMAL_PKG_VERSION}
.if ${_PKG_STATUS} == "<"
-IGNORE= You need pkg(8) at least version ${MINIMAL_PKG_VERSION} and you have ${_PKG_VERSION} please consider upgrading pkg(8) first
+IGNORE= pkg(8) must be version ${MINIMAL_PKG_VERSION} or greater, but you have ${_PKG_VERSION}. You must upgrade pkg(8) first
.endif
.endif