aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-05-30 20:50:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-05-30 20:50:05 +0000
commit738eb15d736491dc2dd07ecad6304f1484933266 (patch)
tree7e4bf8320eddb59378dbd3be06f728646163d107 /Mk/bsd.port.mk
parent17091cda9dea3643658c7cbcdf4183d3ab471902 (diff)
downloadports-738eb15d736491dc2dd07ecad6304f1484933266.tar.gz
ports-738eb15d736491dc2dd07ecad6304f1484933266.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index eedeef38e276..ed43d76ace4d 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6006,9 +6006,9 @@ DEFOPTIONS+= ${opt} "${${opt}_DESC:S|"||g:S|'| |g}" on
. for opt in ${OPTIONS_MULTI_${multi}}
_COMPLETE_OPTIONS_LIST+= ${opt}
. if empty(PORT_OPTIONS:M${opt})
-DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC}" off
+DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC:S|"||g:S|'| |g}" off
. else
-DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC}" on
+DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC:S|"||g:S|'| |g}" on
. endif
. endfor
.endfor
@@ -6016,9 +6016,9 @@ DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC}" on
. for opt in ${OPTIONS_SINGLE_${single}}
_COMPLETE_OPTIONS_LIST+= ${opt}
. if empty(PORT_OPTIONS:M${opt})
-DEFOPTIONS+= ${opt} "S(${single}): ${${opt}_DESC}" off
+DEFOPTIONS+= ${opt} "S(${single}): ${${opt}_DESC:S|"||g:S|'| |g}" off
. else
-DEFOPTIONS+= ${opt} "S(${single}): ${${opt}_DESC}" on
+DEFOPTIONS+= ${opt} "S(${single}): ${${opt}_DESC:S|"||g:S|'| |g}" on
. endif
. endfor
.endfor
@@ -6110,7 +6110,7 @@ showconfig:
@${ECHO_MSG} -n " ${opt}=on"
. endif
. if !empty(${opt}_DESC)
- @${ECHO_MSG} -n ": "${${opt}_DESC}
+ @${ECHO_MSG} -n ": "${${opt}_DESC:Q}
. endif
@${ECHO_MSG} ""
.endfor
@@ -6124,7 +6124,7 @@ showconfig:
@${ECHO_MSG} -n " ${opt}=on"
. endif
. if !empty(${opt}_DESC)
- @${ECHO_MSG} -n ": "${${opt}_DESC}
+ @${ECHO_MSG} -n ": "${${opt}_DESC:Q}
. endif
@${ECHO_MSG} ""
. endfor
@@ -6140,7 +6140,7 @@ showconfig:
@${ECHO_MSG} -n " ${opt}=on"
. endif
. if !empty(${opt}_DESC)
- @${ECHO_MSG} -n ": "${${opt}_DESC}
+ @${ECHO_MSG} -n ": "${${opt}_DESC:Q}
. endif
@${ECHO_MSG} ""
. endfor