aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-04-07 12:51:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-04-07 12:51:47 +0000
commite697ae3387ad4b9d752577e9e4a8ef6b58356b2e (patch)
treed2b126864b10e763c0d3e47769c5c75e9e314052 /Mk/bsd.port.mk
parentd3a462f81cdae4a076d488f45313c3930819ebb8 (diff)
downloadports-e697ae3387ad4b9d752577e9e4a8ef6b58356b2e.tar.gz
ports-e697ae3387ad4b9d752577e9e4a8ef6b58356b2e.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 915600beb18a..edaec87e3fe1 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3303,8 +3303,8 @@ check-vulnerable:
.endif
# set alg to any of SIZE, MD5, SHA256 (or any other checksum algorithm):
-DISTINFO_DATA?= DIR=${DIST_SUBDIR}; ${AWK} -v alg=$$alg \
- -v file=$${DIR:+$$DIR/}$${file} \
+DISTINFO_DATA?= if [ \( -n "${DISABLE_SIZE}" -a -n "${NO_CHECKSUM}" \) -o ! -f "${MD5_FILE}" ]; then exit; fi; \
+ DIR=${DIST_SUBDIR}; ${AWK} -v alg=$$alg -v file=$${DIR:+$$DIR/}$${file} \
'$$1 == alg && $$2 == "(" file ")" {print $$4}' ${MD5_FILE}
# Fetch