aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-10-01 14:33:24 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-10-01 14:33:24 +0000
commitf6fd84cfb5b90b0c0d1c956223fab8938d36660f (patch)
tree7b8c3b148e7f2ecce6346c5716ffb491778d9701 /Mk/bsd.port.mk
parent37203c22d9b7d640f787950f4f75e36b40e63219 (diff)
downloadports-f6fd84cfb5b90b0c0d1c956223fab8938d36660f.tar.gz
ports-f6fd84cfb5b90b0c0d1c956223fab8938d36660f.zip
Notes
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 99f086827a83..272437af58c4 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1334,6 +1334,7 @@ INDEXFILE?= INDEX-${OSVERSION:C/([0-9]*)[0-9]{5}/\1/}
PACKAGES?= ${PORTSDIR}/packages
TEMPLATES?= ${PORTSDIR}/Templates
KEYWORDS?= ${PORTSDIR}/Keywords
+WRAPPERSDIR?= ${PORTSDIR}/Mk/Wrappers/
PATCHDIR?= ${MASTERDIR}/files
FILESDIR?= ${MASTERDIR}/files
@@ -5101,6 +5102,15 @@ create-binary-alias: ${BINARY_LINKDIR}
.endif
.endif
+.if !empty(BINARY_WRAPPERS)
+.if !target(create-binary-wrappers)
+create-binary-wrappers: ${BINARY_LINKDIR}
+.for bin in ${BINARY_WRAPPERS}
+ @${INSTALL_SCRIPT} ${WRAPPERSDIR}/${bin} ${BINARY_LINKDIR}
+.endfor
+.endif
+.endif
+
.if defined(WARNING)
WARNING_WAIT?= 10
show-warnings:
@@ -5201,6 +5211,7 @@ _PATCH_SEQ= 050:ask-license 100:patch-message 150:patch-depends \
${_OPTIONS_patch} ${_USES_patch}
_CONFIGURE_DEP= patch
_CONFIGURE_SEQ= 150:build-depends 151:lib-depends 160:create-binary-alias \
+ 161:create-binary-wrappers \
200:configure-message \
300:pre-configure 450:pre-configure-script \
490:run-autotools-fixup 500:do-configure 700:post-configure \