aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.options.mk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-09-30 19:23:40 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-09-30 19:23:40 +0000
commit3075637e6f755767af4e106b6134500e1e761c61 (patch)
tree225b12f48f799a1049449a007b1a83427f0d1f50 /Mk/bsd.port.options.mk
parentb71ee3e2379c76de860848ee2dc5349c69ac88f5 (diff)
downloadports-3075637e6f755767af4e106b6134500e1e761c61.tar.gz
ports-3075637e6f755767af4e106b6134500e1e761c61.zip
Notes
Diffstat (limited to 'Mk/bsd.port.options.mk')
-rw-r--r--Mk/bsd.port.options.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/Mk/bsd.port.options.mk b/Mk/bsd.port.options.mk
new file mode 100644
index 000000000000..d36f9cd142c2
--- /dev/null
+++ b/Mk/bsd.port.options.mk
@@ -0,0 +1,26 @@
+#-*- mode: Fundamental; tab-width: 4; -*-
+# ex:ts=4
+#
+# bsd.port.options.mk - Allow OPTIONS to determine dependencies
+#
+# usage:
+#
+# .include "bsd.port.pre.mk"
+# <deal with user options>
+# .include "bsd.port.options.mk"
+# <other work, including adjusting dependencies>
+# .include "bsd.port.post.mk"
+#
+# Created by: Shaun Amott <shaun@inerd.com>
+#
+# $FreeBSD$
+#
+
+OPTIONS_Include_MAINTAINER= portmgr@FreeBSD.org
+
+USEOPTIONSMK= yes
+INOPTIONSMK= yes
+
+.include "bsd.port.mk"
+
+.undef INOPTIONSMK