aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2012-06-19 17:18:13 +0000
committerMarcus von Appen <mva@FreeBSD.org>2012-06-19 17:18:13 +0000
commitabb9ab5e87dad08b62f528036a48bbd4deb07bec (patch)
tree8c553e7e3e7da176fb6cb45174fd15078435bf02 /Mk/bsd.python.mk
parentbed5423182aea1e643639fd96b09e7039f323b75 (diff)
downloadports-abb9ab5e87dad08b62f528036a48bbd4deb07bec.tar.gz
ports-abb9ab5e87dad08b62f528036a48bbd4deb07bec.zip
Notes
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index a1edaf989afd..72d50ba2506d 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -676,6 +676,17 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twis
# XXX Hm, should I export some of the variables above to *_ENV?
+# If multiple Python versions are installed and cmake is used, it might
+# happen that a cmake-enabled port using find_package(PythonLibs) and
+# find_package(PythonInterp) detects different Python versions.
+# This in turn might cause it to link against version X while using the
+# includes of version Y, leading to a broken port.
+# Enforce a certain Python version by using PYTHON_VER for cmake.
+.if defined(USE_CMAKE)
+CMAKE_ARGS+= -DPythonLibs_FIND_VERSION:STRING="${PYTHON_VER}" \
+ -DPythonInterp_FIND_VERSION:STRING="${PYTHON_VER}"
+.endif
+
.endif # !defined(_POSTMKINCLUDED) && !defined(Python_Pre_Include)
.if defined(_POSTMKINCLUDED) && !defined(Python_Post_Include)