aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-03-05 00:39:33 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-03-05 00:39:33 +0000
commitd163b8c30c88a66a25bd66ca94cad78d3f387403 (patch)
treed6da205d7d26bf7b78ef27b7c49d02affca12c83 /Mk/bsd.python.mk
parentba8277a1f60c580d7617ea70f02ac18d9f5e75d1 (diff)
downloadports-d163b8c30c88a66a25bd66ca94cad78d3f387403.tar.gz
ports-d163b8c30c88a66a25bd66ca94cad78d3f387403.zip
Notes
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 0852895863ff..fb27759e880e 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -516,7 +516,7 @@ PLIST_FILES+= ${PYDISTUTILS_EGGINFODIR:S;${PREFIX}/;;}/${egg}
. endfor
.endif
-# Fix for programs that build python from a GNU auto* enviornment
+# Fix for programs that build python from a GNU auto* environment
CONFIGURE_ENV+= PYTHON="${PYTHON_CMD}"
# Zope-related variables
@@ -678,6 +678,9 @@ PYDISTUTILS_BUILD_TARGET?= build
PYDISTUTILS_INSTALL_TARGET?= install
.if defined(USE_PYDISTUTILS)
+LDSHARED?= ${CC} -shared
+MAKE_ENV+= LDSHARED="${LDSHARED}"
+
.if !target(do-configure) && !defined(HAS_CONFIGURE) && !defined(GNU_CONFIGURE)
do-configure:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} ${PYDISTUTILS_CONFIGURE_TARGET} ${PYDISTUTILS_CONFIGUREARGS})