aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-18 19:37:49 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-18 19:37:49 +0000
commit37930125af5304a5c9f2a2fe92cdc64ac86fd6b8 (patch)
tree3248404221c57325e075f5ce6f8f114d3d38a698 /Mk/bsd.python.mk
parent12f1dcec7aaed1c7023106589fed8b323eb8cbf1 (diff)
downloadports-37930125af5304a5c9f2a2fe92cdc64ac86fd6b8.tar.gz
ports-37930125af5304a5c9f2a2fe92cdc64ac86fd6b8.zip
Notes
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index c89a6b534204..54438cd29749 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -629,6 +629,7 @@ add-plist-post:
@${AWK} '\
/\.py[co]$$/ && !($$0 ~ "/" pc "/") {id = match($$0, /\/[^\/]+\.py[co]$$/); if (id != 0) {d = substr($$0, 1, RSTART - 1); dirs[d] = 1}; sub(/\.py[co]$$/, "." mt "&"); sub(/[^\/]+\.py[co]$$/, pc "/&"); print; next} \
/^@dirrm / {d = substr($$0, 8); if (d in dirs) {print $$0 "/" pc}; print $$0; next} \
+ /^@dirrmtry / {d = substr($$0, 11); if (d in dirs) {print $$0 "/" pc}; print $$0; next} \
{print} \
END {if (sp in dirs) {print "@dirrm " sp "/" pc}} \
' \