aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2001-04-04 12:32:45 +0000
committerThomas Gellekum <tg@FreeBSD.org>2001-04-04 12:32:45 +0000
commitff1706a9922afc529a29af498a0f62c3b2bb9323 (patch)
tree2e62ec1c0aebc2933d1933cba1066bc3db5ff0c8 /Mk/bsd.python.mk
parent6f997b0ef1c6acc9af3bae92d7629e88cd0784e8 (diff)
downloadports-ff1706a9922afc529a29af498a0f62c3b2bb9323.tar.gz
ports-ff1706a9922afc529a29af498a0f62c3b2bb9323.zip
Notes
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 32b93e7cf473..54f71f25916c 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -37,6 +37,9 @@ Python_Include_MAINTAINER= tg@FreeBSD.org
# default: py${PYTHON_SUFFIX}-
#
# PYTHON_PLATFORM: Python's idea of the OS release.
+# XXX This is faked with ${OPSYS} and ${OSREL} until I
+# find out how to delay defining a variable until after
+# a certain target has been built.
#
# PYTHON_PORTSDIR: The source of your binary's port. Needed for the
# RUN_DEPENDS.
@@ -128,7 +131,7 @@ PYTHON_CMD= ${LOCALBASE}/bin/${PYTHON_VERSION}
PYTHON_INCLUDEDIR= ${LOCALBASE}/include/${PYTHON_VERSION}
PYTHON_LIBDIR= ${LOCALBASE}/lib/${PYTHON_VERSION}
PYTHON_PKGNAMEPREFIX= py${PYTHON_SUFFIX}-
-PYTHON_PLATFORM!= ${PYTHON_CMD} -c 'import sys; print sys.platform'
+PYTHON_PLATFORM!= expr ${OPSYS:L}${OSREL} : '\(.*\)\.'
PYTHON_SITELIBDIR= ${PYTHON_LIBDIR}/site-packages
# dependencies